aboutsummaryrefslogtreecommitdiffstats
path: root/community/dssim/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dssim/APKBUILD')
-rw-r--r--community/dssim/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/dssim/APKBUILD b/community/dssim/APKBUILD
index 8a31edcd066..b3297f40f11 100644
--- a/community/dssim/APKBUILD
+++ b/community/dssim/APKBUILD
@@ -1,18 +1,20 @@
# Contributor: Adam Jensen <adam@acj.sh>
# Maintainer: Adam Jensen <adam@acj.sh>
pkgname=dssim
-pkgver=3.2.0
+pkgver=3.3.1
pkgrel=0
pkgdesc="Tool for image similarity comparison, simulating human perception"
url="https://kornel.ski/dssim"
-arch="all !s390x !riscv64" # limited by rust/cargo
-arch="$arch !ppc64le !armv7 !armhf" # Tries to compile mozjpeg-sys with 'with_simd'
+# arm* / ppc64le: Tries to compile mozjpeg-sys with 'with_simd'
+# s390x: incompatible with load_image crate
+arch="all !s390x !ppc64le !armv7 !armhf"
license="AGPL-3.0-only"
-makedepends="cargo"
+makedepends="cargo cargo-auditable"
+options="net"
source="$pkgname-$pkgver.tar.gz::https://github.com/kornelski/dssim/archive/$pkgver.tar.gz"
build() {
- cargo build --release
+ cargo auditable build --release
}
check() {
@@ -24,5 +26,5 @@ package() {
}
sha512sums="
-c0adcd5f1415d8768de915b33995220543ae07a86a12ffafe24bcd3a51a4afb255162fb054b13704d63c56791faf1580fa26e1309546634a6369aebf6c6603e0 dssim-3.2.0.tar.gz
+1f114575d4fdc0b580b01334266ba833aeaa1aff57a8c17c9773afda318793c88950662a3c15264a2b34e193089b7805017b1261ed13209097d4ebb043383f89 dssim-3.3.1.tar.gz
"