aboutsummaryrefslogtreecommitdiffstats
path: root/community/dtools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dtools/APKBUILD')
-rw-r--r--community/dtools/APKBUILD42
1 files changed, 20 insertions, 22 deletions
diff --git a/community/dtools/APKBUILD b/community/dtools/APKBUILD
index a1a00482d8d..11d39e9b788 100644
--- a/community/dtools/APKBUILD
+++ b/community/dtools/APKBUILD
@@ -9,39 +9,37 @@
# as it rely on building dlang.org (and by extension DMD & co),
# so it is excluded from this package.
pkgname=dtools
-pkgver=2.098.0
-pkgrel=2
+pkgver=2.104.2
+pkgrel=0
pkgdesc="Ancillary tools for the D programming language compiler"
url="https://github.com/dlang/tools"
-arch="x86_64 aarch64"
+arch="x86_64"
license="BSL-1.0"
-makedepends="chrpath ldc llvm-libunwind-dev"
-source="tools-$pkgver.tar.gz::https://github.com/dlang/tools/archive/v$pkgver.tar.gz
- 0001-Add-workaround-for-broken-test.patch"
-
+makedepends="chrpath dmd"
+source="tools-$pkgver.tar.gz::https://github.com/dlang/tools/archive/v$pkgver.tar.gz"
builddir="$srcdir/tools-$pkgver/"
-_outputdir="$builddir/alpine-build/"
+options="!check" # todo
build() {
- ldmd2 -O -release "$builddir/ddemangle.d" -of"$_outputdir/ddemangle"
- ldmd2 -O -release "$builddir/DustMite/dustmite.d" "$builddir/DustMite/splitter.d" "$builddir/DustMite/polyhash.d" -of"$_outputdir/dustmite"
- ldmd2 -O -release "$builddir/rdmd.d" -of"$_outputdir/rdmd"
-
- # Remove redundant rpath
- chrpath -d "$_outputdir/ddemangle" "$_outputdir/dustmite" "$_outputdir/rdmd"
-}
+ msg "building rdmd"
+ dmd -v -of=dtools-rdmd -L=--build-id rdmd.d
-check() {
- ldmd2 -run "$builddir/rdmd_test.d" --rdmd-default-compiler=ldmd2 "$_outputdir/rdmd"
+ for tool in DustMite/dustmite ddemangle catdoc detab tolf dget; do
+ msg "building $tool"
+ ./dtools-rdmd -v --compiler=dmd --build-only -of=dtools-"$(basename $tool)" $tool.d
+ done
}
package() {
- install -s -D "$_outputdir/ddemangle" "$pkgdir/usr/bin/ddemangle"
- install -s -D "$_outputdir/dustmite" "$pkgdir/usr/bin/dustmite"
- install -s -D "$_outputdir/rdmd" "$pkgdir/usr/bin/rdmd"
+ for tool in rdmd ddemangle catdoc detab tolf dget dustmite; do
+ install -Dm755 $pkgname-$tool -t "$pkgdir"/usr/bin
+ done
+ ln -s dtools-rdmd "$pkgdir"/usr/bin/rdmd
+ ln -s dtools-dustmite "$pkgdir"/usr/bin/dustmite
+ ln -s dtools-ddemangle "$pkgdir"/usr/bin/ddemangle
+ chrpath -d "$pkgdir"/usr/bin/*
}
sha512sums="
-a56abcc5b14498d82d8b1de8e545e741d1aae48ffdf904574b36a8f023389c168dc3262be05f8824f0c216f79f8d67edaac9f1f7059b06827119fdf010f27583 tools-2.098.0.tar.gz
-6064a7de3f2e6e031544ffa35823ad198c403f2415a98485df03b2a701cafbfc6ab1640bca71fa5caf4722c36e07bf604a42e6bbeaabe9e9d24d4d86206d8320 0001-Add-workaround-for-broken-test.patch
+a2dcece4a68e0f8791a04b5fc431e240f5052c66e0fc732bc52bbb0345e46d40dba83451123c8ea07ef517121b1831acb1e4e7e4bf501fc320382632bbb543db tools-2.104.2.tar.gz
"