aboutsummaryrefslogtreecommitdiffstats
path: root/community/dub/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dub/APKBUILD')
-rw-r--r--community/dub/APKBUILD43
1 files changed, 7 insertions, 36 deletions
diff --git a/community/dub/APKBUILD b/community/dub/APKBUILD
index 84a2583b6f8..570978ea6a3 100644
--- a/community/dub/APKBUILD
+++ b/community/dub/APKBUILD
@@ -1,22 +1,18 @@
# Contributor: Mathias LANG <pro.mathias.lang@gmail.com>
# Maintainer: Mathias LANG <pro.mathias.lang@gmail.com>
pkgname=dub
-pkgver=1.27.0
-pkgrel=1
+pkgver=1.35.1
+pkgrel=0
pkgdesc="Package and build management system for D"
url="https://code.dlang.org/"
-arch="x86_64" # gdc does not work on 32 bit at this point
+arch="x86_64 aarch64"
license="MIT"
depends="libcurl"
makedepends="chrpath ldc bash curl-dev"
-subpackages="$pkgname-zsh-completion:zsh:noarch $pkgname-doc:doc:noarch"
-source="$pkgname-$pkgver.zip::https://github.com/dlang/dub/archive/v$pkgver.zip"
+subpackages="$pkgname-zsh-completion $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dlang/dub/archive/v$pkgver.tar.gz"
build() {
- # Default abuild.conf has '-Os' which gdmd doesn't support
- # Since we later build the man pages using dub, make it persistent
- DFLAGS=""
-
# The build script needs a DMD-like interface to pass its arguments, so use ldmd2
DMD=ldmd2 GITVER="v$pkgver" ldc2 -run "$builddir/build.d"
@@ -28,7 +24,7 @@ build() {
}
check() {
- bin/dub test
+ bin/dub test --compiler=ldc2
}
package() {
@@ -38,31 +34,6 @@ package() {
cp "$builddir"/scripts/man/*.1 "$pkgdir/usr/share/man/man1/"
}
-zsh() {
- pkgdesc="Zsh completion for dub"
- depends=""
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
-
- mkdir -p "$subpkgdir"/usr/share/zsh/site-functions
- mv "$pkgdir"/usr/share/zsh/site-functions/* \
- "$subpkgdir"/usr/share/zsh/site-functions
- # Satisfy abuild's linter
- rmdir "$pkgdir"/usr/share/zsh/site-functions
-}
-
-doc() {
- pkgdesc="Man pages for dub"
- depends=""
- install_if="$pkgname=$pkgver-r$pkgrel docs"
-
- gzip -9 "$pkgdir"/usr/share/man/man1/*
- mkdir -p "$subpkgdir"/usr/share/man/man1
- mv "$pkgdir"/usr/share/man/man1/* "$subpkgdir"/usr/share/man/man1/
- # Satisfy abuild's linter
- rmdir "$pkgdir"/usr/share/man/man1/
- rmdir "$pkgdir"/usr/share/man/
-}
-
sha512sums="
-dbd10785f188a64949c90fff5f2344b1716b1acbe873f6c6feb4cf2afefd2f6edb714a022f4f848c82d735d2d67c7b36977609c8ea7d8c35545e7e4570c9848e dub-1.27.0.zip
+a371a7ec7003a4a4fb642a3567fce0685c99f4940a02de94d026bdc6fe4e84512b16e4bb57673da4d3b8e25177cc3df329da41862086cecc7b98aec1ebf9e4e7 dub-1.35.1.tar.gz
"