aboutsummaryrefslogtreecommitdiffstats
path: root/community/dub/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dub/APKBUILD')
-rw-r--r--community/dub/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/community/dub/APKBUILD b/community/dub/APKBUILD
index 16350962236..516ff5f6ea6 100644
--- a/community/dub/APKBUILD
+++ b/community/dub/APKBUILD
@@ -5,13 +5,16 @@ pkgver=1.28.0
pkgrel=0
pkgdesc="Package and build management system for D"
url="https://code.dlang.org/"
-arch="x86_64" # gdc does not work on 32 bit at this point
+arch="x86_64 aarch64"
license="MIT"
depends="libcurl"
makedepends="chrpath ldc bash curl-dev"
subpackages="$pkgname-zsh-completion:zsh:noarch $pkgname-doc:doc:noarch"
source="$pkgname-$pkgver.zip::https://github.com/dlang/dub/archive/v$pkgver.zip"
+# pass on edge but fail on 3.16(edge) ..
+[ "$CARCH" = "aarch64" ] && options="$options !check"
+
build() {
# Default abuild.conf has '-Os' which gdmd doesn't support
# Since we later build the man pages using dub, make it persistent