aboutsummaryrefslogtreecommitdiffstats
path: root/community/duckscript/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/duckscript/APKBUILD')
-rw-r--r--community/duckscript/APKBUILD32
1 files changed, 24 insertions, 8 deletions
diff --git a/community/duckscript/APKBUILD b/community/duckscript/APKBUILD
index 1e412095480..8f6883cf7c1 100644
--- a/community/duckscript/APKBUILD
+++ b/community/duckscript/APKBUILD
@@ -1,27 +1,42 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=duckscript
-pkgver=0.8.11
+pkgver=0.9.3
pkgrel=0
pkgdesc="Simple, extendable and embeddable scripting language"
url="https://sagiegurari.github.io/duckscript/"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust/cargo
+arch="all"
license="Apache-2.0"
-makedepends="cargo openssl1.1-compat-dev"
-source="https://github.com/sagiegurari/duckscript/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+makedepends="
+ bzip2-dev
+ cargo
+ cargo-auditable
+ openssl-dev
+ zlib-dev
+ "
+source="https://github.com/sagiegurari/duckscript/archive/$pkgver/duckscript-$pkgver.tar.gz
+ use-zlib.patch
+ "
+
+case "$CARCH" in
+# fails on builders for some reason with new networking
+arm*|aarch64) options="$options !check" ;;
+esac
+
+_cargo_opts="--frozen --no-default-features --features tls-native"
prepare() {
default_prepare
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build --release --frozen
+ cargo auditable build $_cargo_opts --release
}
check() {
- cargo test --frozen
+ cargo test $_cargo_opts
}
package() {
@@ -29,5 +44,6 @@ package() {
}
sha512sums="
-7641f5c5cce97795f5fd71ef926c42624bff6e3d07037ccdd75ca44b4804d07f42b159c08c1e4721dceacd0a4096fc0205334a820158828ef527194a1402f630 duckscript-0.8.11.tar.gz
+d7c70194646083c4613ceff2c5b1a832c145e92829e2db479d9c3dc7d260e50fa270b9be6beefbb4233761fa63f203c5532ac2e7ff3e3d05258ac5a8269c3acc duckscript-0.9.3.tar.gz
+2c4761321af45a356215bfc87e84a2878935e4caf10fd693a1312e3355aece0735d696773026ebec42d0ffab766b1a4b900e70464c9e34efdf90d54072961fdc use-zlib.patch
"