aboutsummaryrefslogtreecommitdiffstats
path: root/community/dune/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dune/APKBUILD')
-rw-r--r--community/dune/APKBUILD37
1 files changed, 29 insertions, 8 deletions
diff --git a/community/dune/APKBUILD b/community/dune/APKBUILD
index 3838ff6ea52..62c218f2024 100644
--- a/community/dune/APKBUILD
+++ b/community/dune/APKBUILD
@@ -1,12 +1,13 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: omni <omni+alpine@hack.org>
+# Contributor: omni <omni+alpine@hack.org>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=dune
-pkgver=3.3.1
+pkgver=3.15.2
pkgrel=0
pkgdesc="A composable build system for OCaml (formerly Jbuilder)"
url="https://dune.build/"
-arch="all !riscv64" # limited by ocaml aport
-license="Apache-2.0"
+arch="all !riscv64 !loongarch64" # ocaml
+license="MIT"
checkdepends="bash"
makedepends="ocaml"
provides="jbuilder=$pkgver-r$pkgrel"
@@ -22,7 +23,7 @@ esac
prepare() {
default_prepare
- # This allows `dune --version` to output the correct version instead of "n/a"
+ # This allows 'dune --version' to output the correct version instead of "n/a"
sed -i "/^(name dune)/a (version $pkgver)" dune-project
# This enables dune-configurator to use the vendored csexp module
sed -i 's/stdune.csexp/dune-configurator.csexp/' vendor/csexp/src/dune
@@ -34,7 +35,7 @@ build() {
--mandir="/usr/share/man" --docdir="/usr/share/doc" \
--datadir="/usr/share"
- ocaml bootstrap.ml --verbose
+ ocaml boot/bootstrap.ml --verbose
./dune.exe build \
-p dune,dune-configurator \
--profile dune-bootstrap --verbose
@@ -63,12 +64,32 @@ emacs() {
configurator() {
pkgdesc="System config helper for the Dune OCaml build system"
- depends="ocaml"
provides="$subpkgname-dev=$pkgver-r$pkgrel"
amove usr/lib/ocaml/"$subpkgname"
}
+prepare_py_provides() {
+ local datadir="${subpkgdir:-$pkgdir}"
+ local pkgbasedir=${pkgbasedir:-"$startdir/pkg"}
+ local controldir="$pkgbasedir"/.control.${subpkgname:-$pkgname}
+
+ options_has "!tracedeps" && return 0
+
+ ocaml4-abuild-find provides \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir" \
+ "$pkgver-r$pkgrel"
+}
+
+scan_python3_dependency() {
+ local controldir="$2" datadir="$3"
+
+ ocaml4-abuild-find requires \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir"
+}
+
sha512sums="
-c87763018a7550c40b9497718b801caa51d39410285cb44ad49b1507571162bf4142cf31186e8c4c762dab874b4cf4d6d0e11220cf910f52a31e46753a04c56a dune-3.3.1.tar.gz
+a15658e439984e0256aedd67b5107d8a347c73752566e8e76f5cf5ef807c3761747f5443bd042d0434a26f73ab18ab283eaf705f797ca31737b45530251210e6 dune-3.15.2.tar.gz
"