aboutsummaryrefslogtreecommitdiffstats
path: root/community/dune/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dune/APKBUILD')
-rw-r--r--community/dune/APKBUILD39
1 files changed, 30 insertions, 9 deletions
diff --git a/community/dune/APKBUILD b/community/dune/APKBUILD
index 2bc5b7c54bd..8cac9330514 100644
--- a/community/dune/APKBUILD
+++ b/community/dune/APKBUILD
@@ -1,12 +1,13 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: omni <omni+alpine@hack.org>
+# Contributor: omni <omni+alpine@hack.org>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=dune
-pkgver=3.2.0
-pkgrel=1
+pkgver=3.15.1
+pkgrel=0
pkgdesc="A composable build system for OCaml (formerly Jbuilder)"
url="https://dune.build/"
-arch="all !riscv64" # limited by ocaml aport
-license="Apache-2.0"
+arch="all !riscv64 !loongarch64" # ocaml
+license="MIT"
checkdepends="bash"
makedepends="ocaml"
provides="jbuilder=$pkgver-r$pkgrel"
@@ -22,7 +23,7 @@ esac
prepare() {
default_prepare
- # This allows `dune --version` to output the correct version instead of "n/a"
+ # This allows 'dune --version' to output the correct version instead of "n/a"
sed -i "/^(name dune)/a (version $pkgver)" dune-project
# This enables dune-configurator to use the vendored csexp module
sed -i 's/stdune.csexp/dune-configurator.csexp/' vendor/csexp/src/dune
@@ -34,7 +35,7 @@ build() {
--mandir="/usr/share/man" --docdir="/usr/share/doc" \
--datadir="/usr/share"
- ocaml bootstrap.ml --verbose
+ ocaml boot/bootstrap.ml --verbose
./dune.exe build \
-p dune,dune-configurator \
--profile dune-bootstrap --verbose
@@ -63,12 +64,32 @@ emacs() {
configurator() {
pkgdesc="System config helper for the Dune OCaml build system"
- depends="ocaml"
provides="$subpkgname-dev=$pkgver-r$pkgrel"
amove usr/lib/ocaml/"$subpkgname"
}
+prepare_py_provides() {
+ local datadir="${subpkgdir:-$pkgdir}"
+ local pkgbasedir=${pkgbasedir:-"$startdir/pkg"}
+ local controldir="$pkgbasedir"/.control.${subpkgname:-$pkgname}
+
+ options_has "!tracedeps" && return 0
+
+ ocaml4-abuild-find provides \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir" \
+ "$pkgver-r$pkgrel"
+}
+
+scan_python3_dependency() {
+ local controldir="$2" datadir="$3"
+
+ ocaml4-abuild-find requires \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir"
+}
+
sha512sums="
-a90ac689d97acab956fd96f16f7c6cfdc95d01785fc14f0d3c8ab39231ff78e8941d2db2fa8cbfaa39bbed8f865e11b628aacae1b22df49512a57d0263c0dca4 dune-3.2.0.tar.gz
+708ca3d487ee845b0e3c464fd5c0ac9b6fcc0d952b5d937a99944a9ae9ca2f037a3520e9f360d50eee925d5853a1f205caee1297920803e3a259dda87c7ebe2c dune-3.15.1.tar.gz
"