aboutsummaryrefslogtreecommitdiffstats
path: root/community/duperemove/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/duperemove/APKBUILD')
-rw-r--r--community/duperemove/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/duperemove/APKBUILD b/community/duperemove/APKBUILD
index 670d58f3408..a4a7569ba63 100644
--- a/community/duperemove/APKBUILD
+++ b/community/duperemove/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=duperemove
-pkgver=0.11.2
+pkgver=0.14.1
pkgrel=0
pkgdesc="Tools for deduping file systems"
url="https://github.com/markfasheh/duperemove"
@@ -10,14 +10,17 @@ license="GPL-2.0-only"
makedepends="glib-dev linux-headers sqlite-dev"
options="!check" # no tests provided
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/markfasheh/duperemove/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/markfasheh/duperemove/archive/refs/tags/v$pkgver.tar.gz"
build() {
- make
+ # Defining this 2 variables prevents make from calling git
+ make VERSION=$pkgver IS_RELEASE=1
}
package() {
make DESTDIR="$pkgdir" PREFIX=/usr install
}
-sha512sums="d2b24c912a3ae4a5b9730ba1369b6174cc6fe252710dc7dae2971816e931558ea68d664bf4c9497630dd9002a71fccc26848ad848831fa45d7a7715ba65378e5 duperemove-0.11.2.tar.gz"
+sha512sums="
+16af9fb002d6e51ce469869507d5d4b8f9576620746337252ad733e6f74ae275c1e83da6af1c203543b9d19890180952d87f9fad4a02d4c4e0a25577ce569191 duperemove-0.14.1.tar.gz
+"