aboutsummaryrefslogtreecommitdiffstats
path: root/community/duperemove/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/duperemove/APKBUILD')
-rw-r--r--community/duperemove/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/community/duperemove/APKBUILD b/community/duperemove/APKBUILD
index 5deb2c0110c..a4a7569ba63 100644
--- a/community/duperemove/APKBUILD
+++ b/community/duperemove/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=duperemove
-pkgver=0.11.3
+pkgver=0.14.1
pkgrel=0
pkgdesc="Tools for deduping file systems"
url="https://github.com/markfasheh/duperemove"
@@ -10,12 +10,11 @@ license="GPL-2.0-only"
makedepends="glib-dev linux-headers sqlite-dev"
options="!check" # no tests provided
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/markfasheh/duperemove/archive/v$pkgver.tar.gz"
-
-[ "$CARCH" = "riscv64" ] && options="$options textrels"
+source="$pkgname-$pkgver.tar.gz::https://github.com/markfasheh/duperemove/archive/refs/tags/v$pkgver.tar.gz"
build() {
- make
+ # Defining this 2 variables prevents make from calling git
+ make VERSION=$pkgver IS_RELEASE=1
}
package() {
@@ -23,5 +22,5 @@ package() {
}
sha512sums="
-0669cbb8a08082b9c2b62aff26759951e3e2c1b2236676ac6d79b9639027f775e4e5a218d1c7930b33ad7cca39726764cce5ac3063dc7d2049eb65fc4431af89 duperemove-0.11.3.tar.gz
+16af9fb002d6e51ce469869507d5d4b8f9576620746337252ad733e6f74ae275c1e83da6af1c203543b9d19890180952d87f9fad4a02d4c4e0a25577ce569191 duperemove-0.14.1.tar.gz
"