aboutsummaryrefslogtreecommitdiffstats
path: root/community/duplicity/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/duplicity/APKBUILD')
-rw-r--r--community/duplicity/APKBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/community/duplicity/APKBUILD b/community/duplicity/APKBUILD
index 67d5b727823..d2f37ad60ca 100644
--- a/community/duplicity/APKBUILD
+++ b/community/duplicity/APKBUILD
@@ -1,35 +1,45 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Contributor: Matt Smith <mcs@darkregion.net>
-# Maintainer: Matt Smith <mcs@darkregion.net>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=duplicity
-pkgver=0.8.19
+pkgver=2.2.3
pkgrel=0
pkgdesc="Encrypted bandwidth-efficient backup using the rsync algorithm"
-url="http://duplicity.nongnu.org/"
+url="https://duplicity.gitlab.io/duplicity-web/"
arch="all"
license="GPL-2.0-or-later"
-depends="python3 py3-boto gnupg ncftp py3-fasteners py3-future"
-makedepends="python3-dev py3-setuptools librsync-dev gettext"
-subpackages="$pkgname-doc $pkgname-lang"
-source="https://launchpad.net/duplicity/0.8-series/$pkgver/+download/duplicity-$pkgver.tar.gz"
+depends="python3 py3-boto3 gpg gpg-agent ncftp py3-fasteners py3-future"
+makedepends="python3-dev py3-setuptools librsync-dev gettext py3-wheel py3-gpep517"
+checkdepends="py3-pytest py3-pexpect"
+subpackages="$pkgname-pyc $pkgname-doc $pkgname-lang"
+source="https://gitlab.com/duplicity/duplicity/-/archive/rel.$pkgver/duplicity-rel.$pkgver.tar.bz2"
+builddir="$srcdir/duplicity-rel.$pkgver"
prepare() {
default_prepare
- # remove dep we don't need
- sed -e '/u"setuptools_scm"/d' -i setup.py
+ # their version setting is broken
+ sed -i "s|\$version|$pkgver|" duplicity/__init__.py
}
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py build_ext
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest testing/unit \
+ --ignore testing/unit/test_cli_main.py
}
package() {
- python3 setup.py install --root "$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="c1a1f5894f8b94ac61bd98270f138c58ef5a68f3624e7e88224b15539ca6e08874df9cebb36b10167d133b1af6a93b29e7bf4084c348b9cd7914ff24415be57c duplicity-0.8.19.tar.gz"
+sha512sums="
+6c476a7c92c13305c89265edc11c188122a478c7e7999202a815e040e3c30912346de904a8456acd1e1893f4e4e8c564460672cc7de21d428e8a6e24452ad423 duplicity-rel.2.2.3.tar.bz2
+"