aboutsummaryrefslogtreecommitdiffstats
path: root/community/dust/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dust/APKBUILD')
-rw-r--r--community/dust/APKBUILD35
1 files changed, 13 insertions, 22 deletions
diff --git a/community/dust/APKBUILD b/community/dust/APKBUILD
index 63813b01c6c..12848adc740 100644
--- a/community/dust/APKBUILD
+++ b/community/dust/APKBUILD
@@ -1,38 +1,30 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=dust
-pkgver=0.7.5
+pkgver=0.9.0
pkgrel=0
pkgdesc="A more intuitive version of du in Rust"
url="https://github.com/bootandy/dust"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust/cargo
+# riscv64: rust broken
+arch="all !riscv64"
license="Apache-2.0"
-makedepends="cargo"
+makedepends="cargo cargo-auditable"
+options="net"
source="https://github.com/bootandy/dust/archive/v$pkgver/dust-$pkgver.tar.gz"
-case "$CARCH" in
- # Some test fail on CI builders (see #/27645).
- armhf | armv7) options="!check";;
-esac
+export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
prepare() {
default_prepare
- # Optimize binary for size (2.5 -> 1.6 MiB).
- cat >> Cargo.toml <<-EOF
-
- [profile.release]
- codegen-units = 1
- lto = true
- opt-level = "z"
- panic = "abort"
- EOF
-
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
+ # this test runs dust and expects the output to match 100%,
+ # which fails a lot of the time on various systems as you can't guarantee that
+ rm tests/test_exact_output.rs
}
build() {
- cargo build --release --frozen
+ cargo auditable build --release --frozen
}
check() {
@@ -40,10 +32,9 @@ check() {
}
package() {
- cargo install --locked --offline --path . --root="$pkgdir/usr"
- rm "$pkgdir"/usr/.crates*
+ install -D -m755 target/release/$pkgname -t "$pkgdir"/usr/bin/
}
sha512sums="
-22459292ed0707b33aa3eb2aba0ee3d46ce597a468e14a28e32391a33d0a591e408fab91e4154c49183544f4fb61dd41750ae4928dbe9b5e5d69714a561b8a8e dust-0.7.5.tar.gz
+de41c92b564bce0d8594221d244445dbacfee313a3b6afb969db229d0eafbf599cd1d1ea7a43f497a7bead69e00b53c5e7b09c4e0bc0fdcf8636bff8906cf7de dust-0.9.0.tar.gz
"