aboutsummaryrefslogtreecommitdiffstats
path: root/community/dust/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dust/APKBUILD')
-rw-r--r--community/dust/APKBUILD46
1 files changed, 23 insertions, 23 deletions
diff --git a/community/dust/APKBUILD b/community/dust/APKBUILD
index 0e5db7740de..5d29e69c6f7 100644
--- a/community/dust/APKBUILD
+++ b/community/dust/APKBUILD
@@ -1,39 +1,36 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=dust
-pkgver=0.8.0
-pkgrel=0
+pkgver=1.0.0
+pkgrel=1
pkgdesc="A more intuitive version of du in Rust"
url="https://github.com/bootandy/dust"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust/cargo
+# riscv64: rust broken
+arch="all !riscv64"
license="Apache-2.0"
-makedepends="cargo"
+makedepends="cargo cargo-auditable"
options="net"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
source="https://github.com/bootandy/dust/archive/v$pkgver/dust-$pkgver.tar.gz"
-case "$CARCH" in
- # Some test fail on CI builders (see #/27645).
- armhf | armv7) options="!check";;
-esac
+export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
prepare() {
default_prepare
- # Optimize binary for size (2.5 -> 1.6 MiB).
- cat >> Cargo.toml <<-EOF
-
- [profile.release]
- codegen-units = 1
- lto = true
- opt-level = "z"
- panic = "abort"
- EOF
-
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
+ # this test runs dust and expects the output to match 100%,
+ # which fails a lot of the time on various systems as you can't guarantee that
+ rm tests/test_exact_output.rs
}
build() {
- cargo build --release --frozen
+ cargo auditable build --release --frozen
}
check() {
@@ -41,10 +38,13 @@ check() {
}
package() {
- cargo install --locked --offline --path . --root="$pkgdir/usr"
- rm "$pkgdir"/usr/.crates*
+ install -D -m755 target/release/$pkgname -t "$pkgdir"/usr/bin/
+ install -D -m644 completions/dust.bash "$pkgdir"/usr/share/bash-completion/completions/dust
+ install -D -m644 completions/dust.fish "$pkgdir"/usr/share/fish/vendor_completions.d/dust.fish
+ install -D -m644 completions/_dust "$pkgdir"/usr/share/zsh/site-functions/_dust
+ install -D -m644 man-page/dust.1 "$pkgdir"/usr/share/man/man1/dust.1
}
sha512sums="
-86285862e642d3c5655ab4f37cb239acf384ff7c519cbda31f5596b017817130bd4e9840b2d5ae993e22cec5c43c1ab468ede4e8004696c9f76c1015afc294fd dust-0.8.0.tar.gz
+21ecf6998f760593604c651067640f959cce46b39ca8adb8833277aa7a72afc212db37a78210ad49a2f305508b84f66057cb0f1162017dc4ad8c6d8932841aa3 dust-1.0.0.tar.gz
"