aboutsummaryrefslogtreecommitdiffstats
path: root/community/dzonegit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dzonegit/APKBUILD')
-rw-r--r--community/dzonegit/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/community/dzonegit/APKBUILD b/community/dzonegit/APKBUILD
index 3ef40ed9dfb..3ea4c68d840 100644
--- a/community/dzonegit/APKBUILD
+++ b/community/dzonegit/APKBUILD
@@ -1,27 +1,32 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=dzonegit
-pkgver=0.14
-pkgrel=2
+pkgver=0.15
+pkgrel=4
pkgdesc="Git hooks to manage a repository of DNS zones"
url="https://github.com/oskar456/dzonegit"
arch="noarch"
license="MIT"
depends="bind-tools git python3"
-makedepends="py3-setuptools py3-pytest-runner"
+makedepends="py3-gpep517 py3-setuptools py3-pytest-runner py3-wheel"
checkdepends="py3-pytest py3-pytest-runner"
-source="https://github.com/oskar456/dzonegit/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://github.com/oskar456/dzonegit/archive/v$pkgver/dzonegit-$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="6a881b75e7415b09e888d37b6b8b79e9ea6a7be0816984319fae9256f62f273f7edce609b69404869afaa80fe067cda59904ae362c3096da73293a7f98f0b19d dzonegit-0.14.tar.gz"
+sha512sums="
+698403132c2e07917041f9cee0c5056cde4fa334c46cb91c3b48e6085a649df0a5be05cef7eac19bdf6fe9bda83542e9290f5bbdbd675df1a1f9b9d9388d70d1 dzonegit-0.15.tar.gz
+"