aboutsummaryrefslogtreecommitdiffstats
path: root/community/dzonegit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dzonegit/APKBUILD')
-rw-r--r--community/dzonegit/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/dzonegit/APKBUILD b/community/dzonegit/APKBUILD
index 07656a6b153..3ea4c68d840 100644
--- a/community/dzonegit/APKBUILD
+++ b/community/dzonegit/APKBUILD
@@ -1,29 +1,32 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=dzonegit
-pkgver=0.13
-pkgrel=0
+pkgver=0.15
+pkgrel=4
pkgdesc="Git hooks to manage a repository of DNS zones"
url="https://github.com/oskar456/dzonegit"
-arch="noarch !x86" # Testsuite fails
+arch="noarch"
license="MIT"
depends="bind-tools git python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-pytest-runner py3-wheel"
checkdepends="py3-pytest py3-pytest-runner"
-source="https://github.com/oskar456/dzonegit/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
-options="!check" # https://github.com/oskar456/dzonegit/issues/15
+subpackages="$pkgname-pyc"
+source="https://github.com/oskar456/dzonegit/archive/v$pkgver/dzonegit-$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="7cb54411e9fb99f09523f6a80c12a646464a23723176a09cccf8903a92c515aab313a16ff3a07c5ade027f1b4918be8e8f5b099404c5b56d9b284b71747e6294 dzonegit-0.13.tar.gz"
+sha512sums="
+698403132c2e07917041f9cee0c5056cde4fa334c46cb91c3b48e6085a649df0a5be05cef7eac19bdf6fe9bda83542e9290f5bbdbd675df1a1f9b9d9388d70d1 dzonegit-0.15.tar.gz
+"