aboutsummaryrefslogtreecommitdiffstats
path: root/community/e2guardian/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/e2guardian/APKBUILD')
-rw-r--r--community/e2guardian/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/e2guardian/APKBUILD b/community/e2guardian/APKBUILD
index a98809b0ec2..a27ad35b211 100644
--- a/community/e2guardian/APKBUILD
+++ b/community/e2guardian/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Noel Kuntze <noel.kuntze@thermi.consulting>
# Maintainer: Noel Kuntze <noel.kuntze@thermi.consulting>
pkgname=e2guardian
-pkgver=5.4.3r
+pkgver=5.5.4r
pkgrel=1
pkgdesc="fork of dansguardian, an open source web content filter"
-url="http://e2guardian.org"
+url="http://e2guardian.org/"
arch="all"
license="GPL-2.0-only"
depends="logrotate"
-makedepends="autoconf automake libtool zlib-dev pcre-dev openssl1.1-compat-dev"
+makedepends="autoconf automake libtool zlib-dev pcre-dev openssl-dev>3"
install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-openrc"
pkgusers="e2guard"
@@ -16,9 +16,13 @@ pkggroups="e2guard"
source="$pkgname-$pkgver.tar.gz::https://github.com/e2guardian/e2guardian/archive/v$pkgver.tar.gz
e2guardian.initd
e2guardian.logrotate
+ 0001-musl-stdio-fix.patch
+ 0002-fix-bool-nullpointer.patch
"
-[ "$CARCH" = "riscv64" ] && options="$options textrels"
+# secfixes:
+# 5.4.5r-r0:
+# - CVE-2021-44273
prepare() {
# bind to 127.0.0.1 by default
@@ -59,6 +63,10 @@ package() {
install -d -o e2guard -g e2guard "$pkgdir"/var/log/e2guardian
}
-sha512sums="2111290db925aa4fc514517a10ffe0a63c170dc09dae7178680831e166d86f8f9c1a05c01e603948858422b0a4456efee08a8fd2b802314d73c451480ccb7d12 e2guardian-5.4.3r.tar.gz
+sha512sums="
+aa3cc5df2533b8fc65e82a1823b64513aa679e060b9f395b603de376d5aa6c7212ee5d11c6550ee8a1874fe2d88415b75bfd286a46ed63d71ca43d54c36db29f e2guardian-5.5.4r.tar.gz
0be16552e4a4b5541d11de50bef1122462bce71a2ad619d9308a8b92afd6bf350acdf1e3a2ccb40442dd5a70d3ca2c40ba70111798f7d356d5c68a0615aebf1a e2guardian.initd
-480188f7f94e0a08707d4c79ff259f0514b8071499e6112a61df56e7bea6407c0d7f323dcdf998cff17c7187d7eafbf0da5d29ce2ab6f819bf0ba38774f43da5 e2guardian.logrotate"
+480188f7f94e0a08707d4c79ff259f0514b8071499e6112a61df56e7bea6407c0d7f323dcdf998cff17c7187d7eafbf0da5d29ce2ab6f819bf0ba38774f43da5 e2guardian.logrotate
+00dc957a8407fe6c17e91ebd60a472a4da48b7e34d78f9f962c91b5db8157ceabe632dc4ddb468241fa0b7a305a4d86d28ff5c49d0f11bcac4ddd5da1256799e 0001-musl-stdio-fix.patch
+bcc55ea05a760b1796ffc66e253d83e02884d3fbe9045cdc87fd7063102375b28928c42b30c2aa454f0cad440fdd6d704d93f37a91fe009089d5ed2c3036c3c8 0002-fix-bool-nullpointer.patch
+"