aboutsummaryrefslogtreecommitdiffstats
path: root/community/easypki/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/easypki/APKBUILD')
-rw-r--r--community/easypki/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/community/easypki/APKBUILD b/community/easypki/APKBUILD
index a13f431462b..efd9cab76f9 100644
--- a/community/easypki/APKBUILD
+++ b/community/easypki/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=easypki
pkgver=1.1.0
-pkgrel=8
+pkgrel=28
pkgdesc="Creating a certificate authority the easy way"
url="https://github.com/google/easypki"
arch="all"
@@ -15,9 +15,9 @@ source="easypki-$pkgver.tar.gz::https://github.com/google/easypki/archive/v$pkgv
overide-version.patch
"
-export GOPATH="$srcdir/go"
-export GOMODCACHE="$srcdir/go-build"
-export GOTMPDIR="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
export GOFLAGS="$GOFLAGS -modcacherw"
@@ -28,7 +28,7 @@ prepare() {
}
build() {
- go build -v -ldflags "-s -w" \
+ go build -v \
-o "$builddir"/easypki ./cmd/easypki
}
@@ -36,7 +36,6 @@ package() {
install -Dm755 easypki "$pkgdir"/usr/bin/easypki
}
-
sha512sums="
733a61645be46d1437b94e31d537c29b6648e2ff805abfba039154c4e765262c60652cdb42df44c17ae1553794cb667515cb03e4c9dfbfab42f9000f876012ca easypki-1.1.0.tar.gz
e5708cf0fbcaf3c6e0375f941360dbc539702a2a4013bcf74fba1e2660ba4b643b6a4040b9bbc160243fb0e5f4abed7a37a93bd095a8fff91dd57c6b8c7c0284 go.mod