aboutsummaryrefslogtreecommitdiffstats
path: root/community/easypki/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/easypki/APKBUILD')
-rw-r--r--community/easypki/APKBUILD56
1 files changed, 20 insertions, 36 deletions
diff --git a/community/easypki/APKBUILD b/community/easypki/APKBUILD
index 2999b7679cc..a4b736c4e19 100644
--- a/community/easypki/APKBUILD
+++ b/community/easypki/APKBUILD
@@ -2,59 +2,43 @@
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=easypki
pkgver=1.1.0
-pkgrel=4
+pkgrel=29
pkgdesc="Creating a certificate authority the easy way"
url="https://github.com/google/easypki"
arch="all"
license="Apache-2.0"
-depends=""
-makedepends="glide go"
-install=""
-subpackages=""
+makedepends="go"
+options="!check"
source="easypki-$pkgver.tar.gz::https://github.com/google/easypki/archive/v$pkgver.tar.gz
- glide.lock
- glide.yaml
+ go.mod
+ go.sum
overide-version.patch
"
-builddir="$srcdir/easypki-$pkgver"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+export GOFLAGS="$GOFLAGS -modcacherw"
prepare() {
- export GOPATH="$startdir"
- cd "$builddir"
- cp "$srcdir"/glide.yaml "$srcdir"/glide.lock .
- glide install --skip-test
default_prepare
+
+ cp "$srcdir"/go.mod "$srcdir"/go.sum .
}
build() {
- export GOPATH="$startdir"
- cd "$builddir"
- go build -v -ldflags "-s -w" \
+ go build -v \
-o "$builddir"/easypki ./cmd/easypki
}
package() {
- cd "$builddir"
install -Dm755 easypki "$pkgdir"/usr/bin/easypki
}
-check() {
- "$builddir"/easypki --help > /dev/null
-}
-
-glide_init() {
- abuild clean deps unpack prepare
- cd "$builddir"
- export GOPATH="$startdir"
- rm -f glide.yaml glide.lock
- glide init --non-interactive
- glide update
- cp glide.yaml glide.lock "$startdir"
- cd "$startdir" && abuild checksum clean
-}
-
-
-sha512sums="733a61645be46d1437b94e31d537c29b6648e2ff805abfba039154c4e765262c60652cdb42df44c17ae1553794cb667515cb03e4c9dfbfab42f9000f876012ca easypki-1.1.0.tar.gz
-34e994dd626c832cb8794bc08617096398782c9242beee2f74c691eec41cebd3db56cbc765094bb571e9934bfef0c4593b6bd8095683be1f74ab992b47ed0476 glide.lock
-c0e0ddd4c608d0a76a8a964a985202a2b8a70a38ca274f1e0714ec22cae5e26d064809b70983ec64805ef558afc9aca9ddb00c24d13f33842c6aedf48b45508b glide.yaml
-bfe4802694b7921a2a015900d56356dfda0e04a153c2b22c3bc03899c4e60fc2d79a425982f8dbdf08cee4fda0e793687f55c549e1ef657b4ef366705a2b9826 overide-version.patch"
+sha512sums="
+733a61645be46d1437b94e31d537c29b6648e2ff805abfba039154c4e765262c60652cdb42df44c17ae1553794cb667515cb03e4c9dfbfab42f9000f876012ca easypki-1.1.0.tar.gz
+e5708cf0fbcaf3c6e0375f941360dbc539702a2a4013bcf74fba1e2660ba4b643b6a4040b9bbc160243fb0e5f4abed7a37a93bd095a8fff91dd57c6b8c7c0284 go.mod
+7b4b463130e91daaa41ab972c9c40d91da9a147380559d052d46be7ff183efdcdb23797a60e7203c807dc4dd96b215e111af84ff1247ac739b7ba8d81615901c go.sum
+bfe4802694b7921a2a015900d56356dfda0e04a153c2b22c3bc03899c4e60fc2d79a425982f8dbdf08cee4fda0e793687f55c549e1ef657b4ef366705a2b9826 overide-version.patch
+"