aboutsummaryrefslogtreecommitdiffstats
path: root/community/ebusd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ebusd/APKBUILD')
-rw-r--r--community/ebusd/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/community/ebusd/APKBUILD b/community/ebusd/APKBUILD
index b253b82660d..8cb619c077b 100644
--- a/community/ebusd/APKBUILD
+++ b/community/ebusd/APKBUILD
@@ -1,21 +1,18 @@
# Contributor: Tim <timstanleydev@gmail.com>
# Maintainer: Tim <timstanleydev@gmail.com>
pkgname=ebusd
-pkgver=22.3
+pkgver=23.2
pkgrel=0
pkgdesc="Daemon for communication with eBUS heating systems"
url="https://github.com/john30/ebusd"
# Upstream only supports these archs.
arch="x86 x86_64 aarch64 armhf armv7"
license="GPL-3.0-only"
-makedepends="argp-standalone cmake mosquitto-dev openssl-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/john30/ebusd/archive/refs/tags/v$pkgver.tar.gz
- cmake.patch
- "
+makedepends="argp-standalone cmake mosquitto-dev openssl-dev samurai"
+source="$pkgname-$pkgver.tar.gz::https://github.com/john30/ebusd/archive/refs/tags/$pkgver.tar.gz"
build() {
- cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DBUILD_TESTING=ON
cmake --build build
@@ -30,6 +27,5 @@ package() {
}
sha512sums="
-565a2a95841680825a29a67dfed2277188951574b3bee7ac75667e264163288d7ebda03112ca5dbeafa96f44e22480203dcde50a46b8cc82597e385e4fa134c2 ebusd-22.3.tar.gz
-9eb3930e924593e2f20eb678c7d3bf5cfbcac5a61ed413f55174cebdcbdb037344483d9ddffcb1a63b11b685028b7ce7012b4b8b7af3086e2818e6f635820cea cmake.patch
+ac19a39f8ddc00792bde4891020022cad46597da54bec71d56a954239b01dd8e8ea79fcb4cce130fc991beb2f4bff01ae7abd95150fcf9e93d65d7b5b93482ce ebusd-23.2.tar.gz
"