aboutsummaryrefslogtreecommitdiffstats
path: root/community/ecl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ecl/APKBUILD')
-rw-r--r--community/ecl/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/ecl/APKBUILD b/community/ecl/APKBUILD
index 47d6f968a14..c60db95129a 100644
--- a/community/ecl/APKBUILD
+++ b/community/ecl/APKBUILD
@@ -1,11 +1,10 @@
# Contributor: Lucas Ramage <ramage.lucas@protonmail.com>
# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
pkgname=ecl
-pkgver=21.2.1
-pkgrel=1
+pkgver=23.9.9
+pkgrel=0
pkgdesc="Embeddable Common Lisp"
-# not compatible with soft-float archs (like mips)
-arch="all !mips !mips64"
+arch="all"
url="https://common-lisp.net/project/ecl"
options="!check"
license="LGPL-2.1-or-later"
@@ -17,7 +16,6 @@ prepare() {
default_prepare
update_config_sub
- update_config_guess
}
build() {
@@ -30,10 +28,17 @@ build() {
--localstatedir=/var/state/ecl \
--enable-boehm=system \
--with-cxx
- make -j1
+ make
+}
+
+check() {
+ make check
}
package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="0849bebe1a8073ea8027cfb172c1d7781d43adb6a8b80585bd08d5674b80422d1648b6fbf718cc17a51c5de6c696514523b4d13a82e8113bf9365c95d3c28648 ecl-21.2.1.tgz"
+
+sha512sums="
+c8f1dcf2bffad7358c3d4e5bb0924cbb69afaf79871e6444bd780a594e1e96e6c547346b7c9c5184a6b12ce920a6a959334cf2a85c3f3ea0e0c8f22f72fb84df ecl-23.9.9.tgz
+"