aboutsummaryrefslogtreecommitdiffstats
path: root/community/editorconfig-checker/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/editorconfig-checker/APKBUILD')
-rw-r--r--community/editorconfig-checker/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/community/editorconfig-checker/APKBUILD b/community/editorconfig-checker/APKBUILD
index 9baf8192c50..eabc96bf3c9 100644
--- a/community/editorconfig-checker/APKBUILD
+++ b/community/editorconfig-checker/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Anjandev Momi <anjan@momi.ca>
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=editorconfig-checker
-pkgver=2.4.0
-pkgrel=0
+pkgver=2.7.0
+pkgrel=7
pkgdesc="A tool to verify that your files are in harmony with your .editorconfig"
url="https://editorconfig-checker.github.io/"
license="MIT"
@@ -12,6 +12,11 @@ options="chmod-clean"
builddir="$srcdir/github.com/editorconfig-checker/$pkgname"
source="$pkgname-$pkgver.tar.gz::https://github.com/editorconfig-checker/editorconfig-checker/archive/$pkgver.tar.gz"
+export GOPATH="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
prepare() {
mkdir -p "$srcdir/github.com/editorconfig-checker"
mv "$srcdir/$pkgname-$pkgver" "$srcdir/github.com/editorconfig-checker/editorconfig-checker"
@@ -20,11 +25,11 @@ prepare() {
check() {
sed -i 's/-race//' Makefile # -buildmode=pie not supported when -race is enabled
- GOPATH="$srcdir" make test
+ make test
}
build() {
- GOPATH="$srcdir" make build
+ make build
}
package() {
@@ -32,5 +37,5 @@ package() {
}
sha512sums="
-5b9d7f959666a23f5aec44866fa7faa47ddf608a954aa74336aca828eaf652ca99bc1883fc973f7c3ea1628dc35d0cf6f26ef498d14a7d958e362d3f68032ed8 editorconfig-checker-2.4.0.tar.gz
+697a0863d4ffa7de498654a266d0e09d71dca8975afec6150ae9131e030fffabd3e4bc7ddf60fc6411d91d7e91c359c1737ad35d02a08acda7ddc320b0d4bd5d editorconfig-checker-2.7.0.tar.gz
"