aboutsummaryrefslogtreecommitdiffstats
path: root/community/editorconfig/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/editorconfig/APKBUILD')
-rw-r--r--community/editorconfig/APKBUILD34
1 files changed, 12 insertions, 22 deletions
diff --git a/community/editorconfig/APKBUILD b/community/editorconfig/APKBUILD
index ec841c06f76..2735918c956 100644
--- a/community/editorconfig/APKBUILD
+++ b/community/editorconfig/APKBUILD
@@ -2,20 +2,18 @@
# Maintainer: Paul Morgan <jumanjiman@gmail.com>
pkgname=editorconfig
_pkgname=$pkgname-core-c
-pkgver=0.12.4
+pkgver=0.12.7
_testname=editorconfig-core-test
-_testver=0.13
+_testver=5ca0b296dc31124d0303895c163013450bd97958
pkgrel=0
pkgdesc="core library written in C for use by plugins supporting EditorConfig parsing"
url="https://github.com/editorconfig/editorconfig-core-c"
arch="all"
license="BSD-2-Clause"
-makedepends="cmake pcre2-dev"
+makedepends="cmake pcre2-dev samurai"
subpackages="lib$pkgname:libs $pkgname-static $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/editorconfig/$_pkgname/archive/v$pkgver.tar.gz
- $_testname-$_testver.tar.gz::https://github.com/editorconfig/$_testname/archive/v$_testver.tar.gz
- use-compiled-binary.patch
- disable-failing-test.patch
+ $_testname-$_testver.tar.gz::https://github.com/editorconfig/$_testname/archive/$_testver.tar.gz
"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -27,35 +25,27 @@ prepare() {
}
build() {
- cmake . \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_C_FLAGS_MINSIZEREL="$CFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_DOCUMENTATION=False
- make
+ cmake --build build
}
check() {
- make test
+ ctest --test-dir build --output-on-failure
}
package() {
- make install DESTDIR="$pkgdir"
+ DESTDIR="$pkgdir" cmake --install build
# Remove symlink to editorconfig-$pkgver.
rm -f "$pkgdir"/usr/bin/"$pkgname"
mv -f "$pkgdir"/usr/bin/"$pkgname"-"$pkgver" "$pkgdir"/usr/bin/"$pkgname"
}
-static() {
- depends=""
- pkgdesc="$pkgdesc (static library)"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
-}
-
-sha512sums="e275d4f77fddd31717a588be15a67a630e693efbddc5e1cf7e9b116b1c1a700fa9bafc1322733aa73a009c78519e00083b151bbc4a5ad55128df2c7360f9a163 editorconfig-0.12.4.tar.gz
-655da56c688e06ec0fb6fee06c89ad2eeef7be48ec2df861ed5ce20417801b4fe8ddf2df31026a8b2fb35fe1ab96daadedceb34f4d3231f931c30f109a5d894b editorconfig-core-test-0.13.tar.gz
-52c969479e62f8cd3fe751cb3421dc06cf39e50eaf7dfd39626cbbdaaa46ec51d348f1a5f4908300855bcebd32760cb4995f2861c2010d5d76a2063be9aea761 use-compiled-binary.patch
-fa283b90a5aa6f64e02963c861456968614dc8cac367bb7583a0d511050ac5339f16d94a0fb47386f197c497a64fcb86ef2ae0c5e8c3111e38b4aeb0880d737d disable-failing-test.patch"
+sha512sums="
+37af762ca5b9a83cb9062457ab5dd354c883a4e71329e84f7f49516dad02c04f5105753ad1dbfc41d63aeb24bbbb0a1b6a2a84215fddf8c34e6cff46f3dcd656 editorconfig-0.12.7.tar.gz
+df5f772cef2f97bb1a4ebc4fec4e51d0e49949a12649e07ff06d1afa45fca2f2f4fd69386a74f04b583e11235a9820392dffd8abd7c480ba7c1b75e944333099 editorconfig-core-test-5ca0b296dc31124d0303895c163013450bd97958.tar.gz
+"