aboutsummaryrefslogtreecommitdiffstats
path: root/community/edk2
diff options
context:
space:
mode:
Diffstat (limited to 'community/edk2')
-rw-r--r--community/edk2/APKBUILD22
-rw-r--r--community/edk2/build-hack.patch13
2 files changed, 13 insertions, 22 deletions
diff --git a/community/edk2/APKBUILD b/community/edk2/APKBUILD
index 56fabff78d2..ec9f9ce7f39 100644
--- a/community/edk2/APKBUILD
+++ b/community/edk2/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=edk2
-pkgver=0.0.20161115
-_commitid=e242cdfb307a6dfe2c0f75c4719f5c1f6b418625
-pkgrel=2
+pkgver=0.0.20170624
+_commitid=vUDK2017
+pkgrel=0
pkgdesc="EFI Development Kit II"
-url="http://www.tianocore.org/edk2/"
+url="https://github.com/tianocore/tianocore.github.io/wiki/EDK-II/"
arch="x86_64"
license="BSD"
depends=""
@@ -66,16 +66,20 @@ export PYTHONPATH=/usr/share/$pkgname/Python
exec python '/usr/share/$pkgname/Python/$i/$i.py' "$@"' > "$pkgdir"/usr/bin/$i
chmod +x "$pkgdir"/usr/bin/$i
done
+ install -d "$pkgdir"/usr/share/OVMF
+ install Build/Ovmf${TARGET_ARCH}/${RELEASE}_${TOOLCHAIN}/FV/OVMF*.fd "$pkgdir"/usr/share/OVMF/
}
ovmf() {
pkgdesc="Open Virtual Machine Firmware (OVMF) BIOS"
license="BSD MIT"
- cd "$builddir"
- mkdir -p "$subpkgdir"/usr/share/$subpkgname/
- install Build/Ovmf${TARGET_ARCH}/${RELEASE}_${TOOLCHAIN}/FV/OVMF.fd "$subpkgdir"/usr/share/$subpkgname/bios.bin
+
+ mkdir -p "$subpkgdir"/usr/share/$subpkgname
+ mv "$pkgdir"/usr/share/OVMF "$subpkgdir"/usr/share/
+ # compat symlink
+ ln -s ../OVMF/OVMF.fd "$subpkgdir"/usr/share/ovmf/bios.bin
}
-sha512sums="5666190aa7e53082649c2f16eee0d75509cce3212fe82ec7ddd2101e04b7506fd3e8702f386a472bd9aea9515f588117ec367da50315c5c25c669110a5572a97 edk2-0.0.20161115.tar.gz
-29158db1d54922f32215892bec0542176d64de4501fcdb1535508bb48b25e1f364ccd57b58aca07f2415c4654f76409dd64e40f5066db3fb9284a7217bbc2230 build-hack.patch"
+sha512sums="d941a661d570b0f69962105920b3524c4aac1f4883468914305eb68015148d70f6593c52872a79a6143cf87dc44e9ce2b8957834b4524cb8a04b12473c6d7d81 edk2-0.0.20170624.tar.gz
+a7d4ab2c82b62ba01c86e59f53bd3896d661c9bfbb9db9598734155b66d5fe03eca4a2a9993a14d3bf555992c6d01ba5d7a15868ff9ec6ed98b8a9b3895bb7df build-hack.patch"
diff --git a/community/edk2/build-hack.patch b/community/edk2/build-hack.patch
index 5573717b0d4..98d7c1233b7 100644
--- a/community/edk2/build-hack.patch
+++ b/community/edk2/build-hack.patch
@@ -1,5 +1,4 @@
VfrCompile seg.faults with fortify enabled. It's probably broken.
-VolInfo does not compile due to -fshort-wchar not being supported by musl. The only major problem is the printf, so comment it out.
diff -ru a/edk2-e242cdfb307a6dfe2c0f75c4719f5c1f6b418625/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp b/edk2-e242cdfb307a6dfe2c0f75c4719f5c1f6b418625/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp
--- edk2-e242cdfb307a6dfe2c0f75c4719f5c1f6b418625/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp 2016-11-16 10:01:14.000000000 +0200
@@ -12,15 +11,3 @@ diff -ru a/edk2-e242cdfb307a6dfe2c0f75c4719f5c1f6b418625/BaseTools/Source/C/VfrC
#include "stdio.h"
#include "stdlib.h"
#include "CommonLib.h"
-diff -ru a/edk2-e242cdfb307a6dfe2c0f75c4719f5c1f6b418625/BaseTools/Source/C/VolInfo/VolInfo.c b/edk2-e242cdfb307a6dfe2c0f75c4719f5c1f6b418625/BaseTools/Source/C/VolInfo/VolInfo.c
---- edk2-e242cdfb307a6dfe2c0f75c4719f5c1f6b418625/BaseTools/Source/C/VolInfo/VolInfo.c 2016-11-16 10:01:14.000000000 +0200
-+++ edk2-e242cdfb307a6dfe2c0f75c4719f5c1f6b418625/BaseTools/Source/C/VolInfo/VolInfo.c 2016-11-16 11:12:40.182415584 +0200
-@@ -1714,7 +1714,7 @@
- break;
-
- case EFI_SECTION_USER_INTERFACE:
-- printf (" String: %ls\n", (wchar_t *) &((EFI_USER_INTERFACE_SECTION *) Ptr)->FileNameString);
-+ //printf (" String: %ls\n", (wchar_t *) &((EFI_USER_INTERFACE_SECTION *) Ptr)->FileNameString);
- break;
-
- case EFI_SECTION_FIRMWARE_VOLUME_IMAGE: