aboutsummaryrefslogtreecommitdiffstats
path: root/community/efibootmgr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/efibootmgr/APKBUILD')
-rw-r--r--community/efibootmgr/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/efibootmgr/APKBUILD b/community/efibootmgr/APKBUILD
new file mode 100644
index 00000000000..38be6c2b032
--- /dev/null
+++ b/community/efibootmgr/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
+pkgname=efibootmgr
+pkgver=17
+pkgrel=0
+pkgdesc="Linux user-space application to modify the Intel Extensible Firmware Interface"
+url="https://github.com/rhboot/efibootmgr"
+arch="x86 x86_64 armhf armv7 aarch64"
+license="GPL-2.0"
+depends=""
+makedepends="efivar-dev linux-headers popt-dev gettext-dev"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rhboot/$pkgname/archive/$pkgver.tar.gz
+ musl-gettext.patch
+ efivar.patch"
+builddir="$srcdir/efibootmgr-$pkgver"
+
+build() {
+ cd "$builddir"
+ PCDIR=/usr/lib/pkgconfig EFIDIR="/boot/efi" make
+}
+
+package() {
+ cd "$builddir"
+ EFIDIR="/boot/efi" make DESTDIR="$pkgdir" install
+}
+
+check() {
+ "$builddir"/src/efibootdump --help > /dev/null
+ "$builddir"/src/efibootmgr --help > /dev/null
+}
+
+sha512sums="10c7ad9a79f23dcd4708dc4f42701196af7aa11f5e9a6468ea51f7013d4caeba6c92527ba1304f6e3b2ef3b51b3b69ea1a30f81bb099a8aea49eeb30eb631e1d efibootmgr-17.tar.gz
+3ed49c6d267e6f14bf43207fecb55ebc984f6fbd15d77cd1b8f466c8d0a4c3ab9bb276e8ed183b5ab0129fde5c06ffcd0450ffb7dad0edfa18b4c472e481373b musl-gettext.patch
+a8f4b37e9c0c55a3b2d20f733606653add0219066b9a46b0878885023480747936ad015a52363ceece481ae4d8b702aaa710d9fde2334aae48f97f650416e129 efivar.patch"