aboutsummaryrefslogtreecommitdiffstats
path: root/community/electrum/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/electrum/APKBUILD')
-rw-r--r--community/electrum/APKBUILD37
1 files changed, 24 insertions, 13 deletions
diff --git a/community/electrum/APKBUILD b/community/electrum/APKBUILD
index 54d753170f7..c07c0af8cbf 100644
--- a/community/electrum/APKBUILD
+++ b/community/electrum/APKBUILD
@@ -1,14 +1,13 @@
# Maintainer: MichaƂ Adamski <michal@ert.pl>
pkgname=electrum
-pkgver=4.1.3
-pkgrel=0
+pkgver=4.5.4
+pkgrel=1
pkgdesc="Lightweight Bitcoin Wallet"
url="https://electrum.org/"
arch="noarch"
license="MIT"
depends="
libsecp256k1
- python3
py3-aiohttp
py3-aiohttp-socks
py3-aiorpcx
@@ -17,31 +16,43 @@ depends="
py3-certifi
py3-dnspython
py3-ecdsa
+ py3-jsonpatch
py3-protobuf
py3-pycryptodomex
py3-qrcode
"
-
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="py3-pytest-xdist py3-cryptography py3-pyaes"
+subpackages="$pkgname-pyc"
source="
- https://download.electrum.org/$pkgver/Electrum-$pkgver.tar.gz
+ electrum-$pkgver.tar.gz::https://github.com/spesmilo/electrum/archive/refs/tags/$pkgver.tar.gz
0001-apk-add-instead-of-apt-get-install.patch
"
-builddir="$srcdir/Electrum-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py check
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto \
+ --ignore tests/test_qml_types.py \
+ tests
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- rm -r "${pkgdir:?}"/home
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
+
sha512sums="
-eb1ea44e4bb3573a2035e51b8d0b1f36ddf150368fced2bf27c10939c2e81034505ad543bf6c272b298f5d1ebd8ef2610e5cdf75b758439bb9c007e1c9ccb5e8 Electrum-4.1.3.tar.gz
-ccc8b3e286369a76d396e52e3db9b20a493dec179346a64a2fe4266d3ab1d775c07cf742d9c602f606030ecd95589a27f709e5f4b7b996fa5ccc0feb854dda9b 0001-apk-add-instead-of-apt-get-install.patch
+3fda9a931067e35d8bc11da8855553a1208428975fe65b0fc20eb26bdd2c3840b5c3ed4261e60344c7256461887d286e432568ef385d9c6b1216e708e099b34b electrum-4.5.4.tar.gz
+797f684a8df30176129335e9e09868be8a4db7a76b3b89dd0b48d93e577a90aa378839a7cc2bf7804494e1cfea77e392fcf74d55243ad51531f4e42c6c747aac 0001-apk-add-instead-of-apt-get-install.patch
"