aboutsummaryrefslogtreecommitdiffstats
path: root/community/electrum
diff options
context:
space:
mode:
Diffstat (limited to 'community/electrum')
-rw-r--r--community/electrum/0001-apk-add-instead-of-apt-get-install.patch12
-rw-r--r--community/electrum/APKBUILD39
2 files changed, 32 insertions, 19 deletions
diff --git a/community/electrum/0001-apk-add-instead-of-apt-get-install.patch b/community/electrum/0001-apk-add-instead-of-apt-get-install.patch
index 29d22015109..2431d3a95c9 100644
--- a/community/electrum/0001-apk-add-instead-of-apt-get-install.patch
+++ b/community/electrum/0001-apk-add-instead-of-apt-get-install.patch
@@ -9,14 +9,14 @@ index 1e1d2831f..b7fe2c42d 100644
--- a/electrum/gui/qt/__init__.py
+++ b/electrum/gui/qt/__init__.py
@@ -34,7 +34,7 @@ from typing import Optional, TYPE_CHECKING, List
- try:
- import PyQt5
- except Exception:
-- sys.exit("Error: Could not import PyQt5 on Linux systems, you may try 'sudo apt-get install python3-pyqt5'")
-+ sys.exit("Error: Could not import PyQt5 on Linux systems, you may try 'sudo apk add py3-qt5'")
+ from electrum import GuiImportError
+ raise GuiImportError(
+ "Error: Could not import PyQt5. On Linux systems, "
+- "you may try 'sudo apt-get install python3-pyqt5'") from e
++ "you may try 'doas apk add py3-qt5'") from e
from PyQt5.QtGui import QGuiApplication
- from PyQt5.QtWidgets import (QApplication, QSystemTrayIcon, QWidget, QMenu,
+ from PyQt5.QtWidgets import QApplication, QSystemTrayIcon, QWidget, QMenu, QMessageBox
--
2.25.1
diff --git a/community/electrum/APKBUILD b/community/electrum/APKBUILD
index 54af5244b35..c07c0af8cbf 100644
--- a/community/electrum/APKBUILD
+++ b/community/electrum/APKBUILD
@@ -1,14 +1,13 @@
# Maintainer: MichaƂ Adamski <michal@ert.pl>
pkgname=electrum
-pkgver=4.0.5
-pkgrel=0
+pkgver=4.5.4
+pkgrel=1
pkgdesc="Lightweight Bitcoin Wallet"
url="https://electrum.org/"
arch="noarch"
license="MIT"
depends="
libsecp256k1
- python3
py3-aiohttp
py3-aiohttp-socks
py3-aiorpcx
@@ -17,29 +16,43 @@ depends="
py3-certifi
py3-dnspython
py3-ecdsa
+ py3-jsonpatch
py3-protobuf
py3-pycryptodomex
py3-qrcode
"
-
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="py3-pytest-xdist py3-cryptography py3-pyaes"
+subpackages="$pkgname-pyc"
source="
- https://download.electrum.org/$pkgver/Electrum-$pkgver.tar.gz
+ electrum-$pkgver.tar.gz::https://github.com/spesmilo/electrum/archive/refs/tags/$pkgver.tar.gz
0001-apk-add-instead-of-apt-get-install.patch
"
-builddir="$srcdir/Electrum-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py check
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto \
+ --ignore tests/test_qml_types.py \
+ tests
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- rm -r "${pkgdir:?}"/home
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="573ba287945bfed2c4bf97976b76cd80c4ba846c0806a47c3dc2bbd6a2d70f515eb32b58aef9ff8e56a7929bb594c64ee1829bc1a351405d3b7872972c8ceac6 Electrum-4.0.5.tar.gz
-ccc8b3e286369a76d396e52e3db9b20a493dec179346a64a2fe4266d3ab1d775c07cf742d9c602f606030ecd95589a27f709e5f4b7b996fa5ccc0feb854dda9b 0001-apk-add-instead-of-apt-get-install.patch"
+
+sha512sums="
+3fda9a931067e35d8bc11da8855553a1208428975fe65b0fc20eb26bdd2c3840b5c3ed4261e60344c7256461887d286e432568ef385d9c6b1216e708e099b34b electrum-4.5.4.tar.gz
+797f684a8df30176129335e9e09868be8a4db7a76b3b89dd0b48d93e577a90aa378839a7cc2bf7804494e1cfea77e392fcf74d55243ad51531f4e42c6c747aac 0001-apk-add-instead-of-apt-get-install.patch
+"