aboutsummaryrefslogtreecommitdiffstats
path: root/community/entr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/entr/APKBUILD')
-rw-r--r--community/entr/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/entr/APKBUILD b/community/entr/APKBUILD
index 6f2dc02d282..08f8804db8f 100644
--- a/community/entr/APKBUILD
+++ b/community/entr/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=entr
-pkgver=5.1
+pkgver=5.5
pkgrel=0
pkgdesc="Event Notify Test Runner: Run arbitrary commands when files change"
url="https://eradman.com/entrproject"
@@ -9,19 +9,24 @@ arch="all"
license="ISC"
subpackages="$pkgname-doc"
makedepends="vim mercurial file util-linux"
-checkdepends="bash tmux"
+checkdepends="bash tmux util-linux-misc"
source="https://eradman.com/entrproject/code/entr-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+
+ # The test script is not compatibile with BusyBox ash
+ # and also uses several GNU extensions (e.g. function syntax).
+ sed -i system_test.sh -e 's|#!/bin/sh|#!/bin/bash|'
+}
+
build() {
./configure
make
}
check() {
- make test
-
- # FIXME: The tmux invocation in the functional tests blocks the builders
- # make regress
+ SHELL=/bin/sh script --return --quiet -c "make -j1 test" /dev/null
}
package() {
@@ -29,5 +34,5 @@ package() {
}
sha512sums="
-b8ee7dae5bda503af814eb109a0180c9864fa1b1cf5a2fe53c9915b6536e9471f8293c63d138d881da7bf70dfee24a6c271b82ecb6ccb2cb6ea664cabedba202 entr-5.1.tar.gz
+5150744142cf1639289c2d845cf8cd3cbc0ef57fce8285bc0e2908c430d8344659ff064810e175e69bd8a6f06144734b2efa4d733e0fba7fec83a1f48d053a0d entr-5.5.tar.gz
"