aboutsummaryrefslogtreecommitdiffstats
path: root/community/entr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/entr/APKBUILD')
-rw-r--r--community/entr/APKBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/community/entr/APKBUILD b/community/entr/APKBUILD
index 327719cf17f..08f8804db8f 100644
--- a/community/entr/APKBUILD
+++ b/community/entr/APKBUILD
@@ -1,16 +1,24 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=entr
-pkgver=4.8
+pkgver=5.5
pkgrel=0
pkgdesc="Event Notify Test Runner: Run arbitrary commands when files change"
-url="http://entrproject.org"
-arch="all !86" # limited by mercurial
+url="https://eradman.com/entrproject"
+arch="all"
license="ISC"
subpackages="$pkgname-doc"
makedepends="vim mercurial file util-linux"
-checkdepends="bash tmux"
-source="http://entrproject.org/code/entr-$pkgver.tar.gz"
+checkdepends="bash tmux util-linux-misc"
+source="https://eradman.com/entrproject/code/entr-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+
+ # The test script is not compatibile with BusyBox ash
+ # and also uses several GNU extensions (e.g. function syntax).
+ sed -i system_test.sh -e 's|#!/bin/sh|#!/bin/bash|'
+}
build() {
./configure
@@ -18,14 +26,13 @@ build() {
}
check() {
- make test
-
- # FIXME: The tmux invocation in the functional tests blocks the builders
- # make regress
+ SHELL=/bin/sh script --return --quiet -c "make -j1 test" /dev/null
}
package() {
PREFIX="$pkgdir/usr" make install
}
-sha512sums="fc99a257fe9a30a9b08f0b6283f9ee3b65c38362744842dd976a4ac7749df7f6ff630235443af17f664f9cbf2a197dbb8c1114fe491e675921745294b4fa4d8f entr-4.8.tar.gz"
+sha512sums="
+5150744142cf1639289c2d845cf8cd3cbc0ef57fce8285bc0e2908c430d8344659ff064810e175e69bd8a6f06144734b2efa4d733e0fba7fec83a1f48d053a0d entr-5.5.tar.gz
+"