aboutsummaryrefslogtreecommitdiffstats
path: root/community/entr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/entr/APKBUILD')
-rw-r--r--community/entr/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/entr/APKBUILD b/community/entr/APKBUILD
index 2aafd957580..08f8804db8f 100644
--- a/community/entr/APKBUILD
+++ b/community/entr/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=entr
-pkgver=5.0
+pkgver=5.5
pkgrel=0
pkgdesc="Event Notify Test Runner: Run arbitrary commands when files change"
url="https://eradman.com/entrproject"
@@ -9,19 +9,24 @@ arch="all"
license="ISC"
subpackages="$pkgname-doc"
makedepends="vim mercurial file util-linux"
-checkdepends="bash tmux"
+checkdepends="bash tmux util-linux-misc"
source="https://eradman.com/entrproject/code/entr-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+
+ # The test script is not compatibile with BusyBox ash
+ # and also uses several GNU extensions (e.g. function syntax).
+ sed -i system_test.sh -e 's|#!/bin/sh|#!/bin/bash|'
+}
+
build() {
./configure
make
}
check() {
- make test
-
- # FIXME: The tmux invocation in the functional tests blocks the builders
- # make regress
+ SHELL=/bin/sh script --return --quiet -c "make -j1 test" /dev/null
}
package() {
@@ -29,5 +34,5 @@ package() {
}
sha512sums="
-f485efb7d05f1d099c85d8af2f313e3ed2f36720483afc3004479b5b8754c60c52a108b827efd017c674f01d6ced2878a317addef3960c8cdf9e6b142f2ad5fd entr-5.0.tar.gz
+5150744142cf1639289c2d845cf8cd3cbc0ef57fce8285bc0e2908c430d8344659ff064810e175e69bd8a6f06144734b2efa4d733e0fba7fec83a1f48d053a0d entr-5.5.tar.gz
"