aboutsummaryrefslogtreecommitdiffstats
path: root/community/eog/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/eog/APKBUILD')
-rw-r--r--community/eog/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/community/eog/APKBUILD b/community/eog/APKBUILD
index 64ae4a7647a..3181f80b9b4 100644
--- a/community/eog/APKBUILD
+++ b/community/eog/APKBUILD
@@ -1,11 +1,12 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer:
pkgname=eog
-pkgver=42.0
+pkgver=45.3
pkgrel=0
-pkgdesc="An image viewer for GNOME"
+pkgdesc="Image viewer for GNOME"
url="https://wiki.gnome.org/Apps/EyeOfGnome"
-arch="all !s390x !riscv64" # limited by librsvg -> rust
+# s390x: blocked by exempi-dev
+arch="all !s390x"
license="GPL-2.0-or-later"
depends="gsettings-desktop-schemas"
depends_dev="
@@ -24,7 +25,6 @@ makedepends="
$depends_dev
itstool
libhandy1-dev
- libxml2-utils
meson
"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
@@ -32,12 +32,13 @@ source="https://download.gnome.org/sources/eog/${pkgver%.*}/eog-$pkgver.tar.xz"
build() {
abuild-meson \
- output .
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -45,5 +46,5 @@ package() {
}
sha512sums="
-3901dbac9a371bac1e1bdc143e3d257a8e25fa2743a97bd9f9ecdb06e43cd5278edf33a46ab24c5e40babef6825181c986c99d9b4fafead71e04f51e65ae2acb eog-42.0.tar.xz
+21693d659a5eb25bdec968266d7e6a1a6988bcec0bf5c3d914b098001ed4a8e64d7ff628181072fb1aabec1b89b56ed5e7c85e3b06ec79be1c9d7cf1c57d3145 eog-45.3.tar.xz
"