aboutsummaryrefslogtreecommitdiffstats
path: root/community/epiphany/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/epiphany/APKBUILD')
-rw-r--r--community/epiphany/APKBUILD70
1 files changed, 54 insertions, 16 deletions
diff --git a/community/epiphany/APKBUILD b/community/epiphany/APKBUILD
index 52a2a97c6ca..49284f3b632 100644
--- a/community/epiphany/APKBUILD
+++ b/community/epiphany/APKBUILD
@@ -1,31 +1,69 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=epiphany
-pkgver=40.2
+pkgver=46.0
pkgrel=0
-pkgdesc="A simple, clean, beautiful view of the web"
+pkgdesc="Simple, clean, beautiful view of the web"
url="https://wiki.gnome.org/Apps/Web"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy
-arch="all !s390x !mips64 !riscv64"
+arch="all"
license="GPL-3.0-or-later"
-depends="gsettings-desktop-schemas dbus:org.freedesktop.Secrets"
-makedepends="meson iso-codes-dev gtk+3.0-dev gsettings-desktop-schemas-dev
- icu-dev json-glib-dev libdazzle-dev libhandy1-dev libnotify-dev libsecret-dev
- libsoup-dev libxml2-dev nettle-dev sqlite-dev webkit2gtk-dev gcr-dev itstool
- libportal-dev libarchive-dev"
-checkdepends="appstream-glib desktop-file-utils xvfb-run ibus"
-options="!check" # Fail due to our webkitgtk patches!
+depends="
+ dbus:org.freedesktop.Secrets
+ gsettings-desktop-schemas
+ gst-plugins-good
+ "
+makedepends="
+ desktop-file-utils
+ gcr4-dev
+ gsettings-desktop-schemas-dev
+ gst-plugins-base-dev
+ gtk+3.0-dev
+ icu-dev
+ iso-codes-dev
+ itstool
+ json-glib-dev
+ libadwaita-dev
+ libarchive-dev
+ libdazzle-dev
+ libnotify-dev
+ libportal-dev
+ libsecret-dev
+ libxml2-dev
+ meson
+ nettle-dev
+ sqlite-dev
+ webkit2gtk-6.0-dev
+ "
+checkdepends="appstream-glib xvfb-run ibus"
subpackages="$pkgname-lang $pkgname-doc $pkgname-dbg"
source="https://download.gnome.org/sources/epiphany/${pkgver%.*}/epiphany-$pkgver.tar.xz"
+options="!check" # broken
+
+# secfixes:
+# 42.2-r0:
+# - CVE-2022-29536
+# 41.3-r0:
+# - CVE-2021-45085
+# - CVE-2021-45086
+# - CVE-2021-45087
+# - CVE-2021-45088
+
+prepare() {
+ default_prepare
+
+ git init -q
+}
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
check() {
# https://gitlab.gnome.org/GNOME/epiphany/issues/829
- env PATH="$PATH:$builddir/output/src" xvfb-run meson test --no-rebuild -v -C output
+ env PATH="$PATH:$builddir/output/src" xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -33,5 +71,5 @@ package() {
}
sha512sums="
-29a5b7e65f7e5decb3c370fc9ae654727cce30f397ffd3289a9f77f3527f0471c821e3bea0f1a5ab9c1ab44e670898b46e66e41de5cb8c76fabd23b135a4a1a9 epiphany-40.2.tar.xz
+55d1e89294e0f7cfae10b6aa28f43028bd34053e1d829168bf59b9cce8a8128a2ed7e9b94b8665e0f36e03adae845e0a26ff40c83abbc9962f06ac75e3c36a79 epiphany-46.0.tar.xz
"