aboutsummaryrefslogtreecommitdiffstats
path: root/community/eq10q/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/eq10q/APKBUILD')
-rw-r--r--community/eq10q/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/community/eq10q/APKBUILD b/community/eq10q/APKBUILD
index 35c5cc3e52c..ce254ce40c2 100644
--- a/community/eq10q/APKBUILD
+++ b/community/eq10q/APKBUILD
@@ -2,9 +2,9 @@
# Maintainer: Magnus Sandin <magnus.sandin@gmail.com>
pkgname=eq10q
pkgver=2.2
-pkgrel=0
+pkgrel=3
pkgdesc="Audio plugin bundle over the LV2 standard for Linux"
-url="http://eq10q.sourceforge.net"
+url="https://eq10q.sourceforge.net/"
options="!check" # No tests available
arch="x86 x86_64"
license="GPL-3.0-only"
@@ -13,21 +13,20 @@ makedepends="
fftw-dev
gtkmm-dev
lv2-dev
-"
+ samurai
+ "
source="https://downloads.sourceforge.net/project/eq10q/eq10q-$pkgver.tar.gz
-fix_lv2ui_descriptor.patch
-"
+ fix_lv2ui_descriptor.patch
+ "
build() {
- cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=Release
cmake --build build
}
package() {
- DESTDIR="$pkgdir" cmake --install build \
- --prefix /usr/lib/lv2
+ DESTDIR="$pkgdir" cmake --install build --prefix=/usr/lib/lv2
}
sha512sums="