aboutsummaryrefslogtreecommitdiffstats
path: root/community/falkon/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/falkon/APKBUILD')
-rw-r--r--community/falkon/APKBUILD60
1 files changed, 36 insertions, 24 deletions
diff --git a/community/falkon/APKBUILD b/community/falkon/APKBUILD
index de781854ecc..f772d0c542b 100644
--- a/community/falkon/APKBUILD
+++ b/community/falkon/APKBUILD
@@ -1,29 +1,45 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=falkon
-pkgver=3.1.0
-pkgrel=4
+pkgver=24.02.2
+pkgrel=0
pkgdesc="Cross-platform Qt Web Browser"
url="https://github.com/KDE/falkon"
-# armhf blocked by qt5-qtdeclarative
-# mips64, ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# armhf blocked by extra-cmake-modules
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
license="GPL-3.0-or-later"
-depends="qt5-qtbase-sqlite"
-makedepends="cmake python3 qt5-qtbase-dev extra-cmake-modules qt5-qtdeclarative-dev
- qt5-qtwebengine-dev xcb-util-dev libxcb-dev qt5-qtx11extras-dev qt5-qttools-dev
- ki18n-dev karchive-dev kwallet-dev kio-dev kcrash-dev kcoreaddons-dev purpose-dev"
+depends="qt6-qtbase-sqlite"
+makedepends="
+ extra-cmake-modules
+ karchive-dev
+ kcoreaddons-dev
+ kcrash-dev
+ ki18n-dev
+ kio-dev
+ kwallet-dev
+ libxcb-dev
+ openssl-dev>3
+ purpose-dev
+ python3
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ qt6-qttools-dev
+ qt6-qtwebengine-dev
+ samurai
+ xcb-util-dev
+ "
checkdepends="xvfb-run"
subpackages="$pkgname-lang $pkgname-bash-completion:bashcomp:noarch"
-source="https://download.kde.org/stable/falkon/${pkgver%.*}/falkon-$pkgver.tar.xz
- add-missing-include-in-last-qt5.14.patch
- execinfo_h.patch
- fix-qt5.15-build.patch
- "
+_repo_url="https://invent.kde.org/network/falkon.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/falkon-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
@@ -32,10 +48,9 @@ build() {
}
check() {
- cd build
-
# Requires working OpenGL
- xvfb-run ctest -E "falkon-(webviewtest|webtabtest|tabmodeltest)"
+ # qmlhistoryapitest, qmlcookiesapitest, qmltabsapitest and qmlwindowsapitest are SIGTRAP'ing
+ xvfb-run ctest --test-dir build --output-on-failure -E "falkon-(locationbar|webtab|qml-qml(tabsapi|topsitesapi))test" -j1
}
package() {
@@ -51,8 +66,5 @@ bashcomp() {
}
sha512sums="
-c04f97869150b8ab81ae7b01c7137e35ca5c3103c057e01896454bbeda1075372a7831d2dfe7ab66794de0983593df6e46eff47c5cdc2bc959f81b022506f054 falkon-3.1.0.tar.xz
-9ac674e0063574a2117ed81d7209c8bdfd605c39e6eca0dcb2882b5323ff24ae49240837b9aaefea97ac894a7d4becfd1a972e3258bee593da28a471fa7bb2c4 add-missing-include-in-last-qt5.14.patch
-5492b986b8f2156fe8a7af7382c54a82efdc8ccafd5f56a545de8f76d4fb5d4427e75f1387a36d1def3a7667ad44eae75a99580afcacde8b9ab83367cfb75077 execinfo_h.patch
-a1e6c79985b1416e5b4b7fba520d4764bec93828f7ae978d8238bf0a814d34d5c9cf1832f548b9616bed7a77fb7b11d476a84f1c9505e9335bd8af4077ffd860 fix-qt5.15-build.patch
+37493aa624903b4d1fc5fbc8ddc12c7171da8db0f57c8aa9ce9450951538f2eb327102f62ee682da515a6fbb256079dd4e4a814922fdd33d6e74c5a9c4ef7f9b falkon-24.02.2.tar.xz
"