aboutsummaryrefslogtreecommitdiffstats
path: root/community/farstream/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/farstream/APKBUILD')
-rw-r--r--community/farstream/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/farstream/APKBUILD b/community/farstream/APKBUILD
new file mode 100644
index 00000000000..6fccb65eb1a
--- /dev/null
+++ b/community/farstream/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=farstream
+pkgver=0.2.8
+pkgrel=3
+pkgdesc="Libraries for videoconferencing"
+url="http://www.freedesktop.org/wiki/Software/Farstream"
+arch="all"
+license="LGPL-2.0-or-later AND GPL-2.0-or-later"
+depends_dev="libnice-dev gst-plugins-base-dev"
+makedepends="$depends_dev gobject-introspection-dev gstreamer-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://freedesktop.org/software/farstream/releases/farstream/farstream-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+py() {
+ pkgdesc="Python binding for farstream"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="7ec5c57f8778f4107cb628dbf411e38b726152cf78920127dff4423239ff7e4980b6b4f938abba2aa21ab984b1e3053e7e648611322a0ce94df0af576df99a7e farstream-0.2.8.tar.gz"