aboutsummaryrefslogtreecommitdiffstats
path: root/community/fcft/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fcft/APKBUILD')
-rw-r--r--community/fcft/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/fcft/APKBUILD b/community/fcft/APKBUILD
index 5cfccd9edd4..3a6fa763eb4 100644
--- a/community/fcft/APKBUILD
+++ b/community/fcft/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=fcft
-pkgver=2.5.0
+pkgver=3.1.8
pkgrel=0
pkgdesc="Simple library for font loading and glyph rasterization using FontConfig, FreeType and pixman"
-url="https://codeberg.org/dnkl/fcft.git"
+url="https://codeberg.org/dnkl/fcft"
license="MIT"
arch="all"
makedepends="
@@ -16,18 +16,22 @@ makedepends="
tllist-dev
utf8proc-dev
"
-checkdepends="check-dev ttf-dejavu" # tests require a font to be installed
+checkdepends="check-dev font-dejavu font-noto-emoji" # tests require a font to be installed
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://codeberg.org/dnkl/fcft/archive/$pkgver.tar.gz"
builddir="$srcdir/fcft"
build() {
- abuild-meson . output
+ abuild-meson \
+ -Db_lto=true \
+ -Dsvg-backend=nanosvg \
+ -Dtest-text-shaping=true \
+ . output
meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -35,5 +39,5 @@ package() {
}
sha512sums="
-2bd65232ecaf10a4995051eb1409aa8e676365c7d7574e1cd6cbda73e809558572beb0c0bd7e85ee4cf946bfbc83968bef90e54fa70833ab64d70f5439de9bad fcft-2.5.0.tar.gz
+1b1cfbed4e99db8e290a1dcf6c124949f5fb317e225996e63913974f4a52748a04be053cff934c8f8c0b3add22c87f9e3b1c793366431f788529e62d7a7be69c fcft-3.1.8.tar.gz
"