aboutsummaryrefslogtreecommitdiffstats
path: root/community/fclones/musl-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/fclones/musl-fix.patch')
-rw-r--r--community/fclones/musl-fix.patch13
1 files changed, 6 insertions, 7 deletions
diff --git a/community/fclones/musl-fix.patch b/community/fclones/musl-fix.patch
index 338116700cd..f093736af14 100644
--- a/community/fclones/musl-fix.patch
+++ b/community/fclones/musl-fix.patch
@@ -18,7 +18,7 @@ see: https://github.com/pkolaczk/fclones/issues/95
--- a/Cargo.lock
+++ b/Cargo.lock
-@@ -892,8 +892,7 @@ dependencies = [
+@@ -1166,8 +1166,7 @@ dependencies = [
[[package]]
name = "reflink"
version = "0.1.3"
@@ -28,11 +28,9 @@ see: https://github.com/pkolaczk/fclones/issues/95
dependencies = [
"libc",
"winapi",
-diff --git a/Cargo.toml b/Cargo.toml
-index 3f96e5a..c4e1ee1 100644
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -67,10 +67,10 @@ winapi = "0.3"
+--- a/fclones/Cargo.toml
++++ b/fclones/Cargo.toml
+@@ -81,10 +81,10 @@ winapi = "0.3"
winapi-util = "0.1"
[target.'cfg(not(any(target_os = "linux", target_os = "android")))'.dependencies]
@@ -40,7 +38,8 @@ index 3f96e5a..c4e1ee1 100644
+reflink = { git = "https://github.com/nicokoch/reflink.git", rev = "e8d93b465f5d9ad340cd052b64bbc77b8ee107e2" }
[dev-dependencies]
+ assert_matches = "1.5"
-reflink = "0.1"
+reflink = { git = "https://github.com/nicokoch/reflink.git", rev = "e8d93b465f5d9ad340cd052b64bbc77b8ee107e2" }
serde_test = "1.0"
- tempfile = "3.3"
+ tempfile = "3"