aboutsummaryrefslogtreecommitdiffstats
path: root/community/fd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fd/APKBUILD')
-rw-r--r--community/fd/APKBUILD37
1 files changed, 19 insertions, 18 deletions
diff --git a/community/fd/APKBUILD b/community/fd/APKBUILD
index 5bd2ebba99f..e9f08ff2cd0 100644
--- a/community/fd/APKBUILD
+++ b/community/fd/APKBUILD
@@ -1,13 +1,14 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=fd
-pkgver=8.4.0
+pkgver=9.0.0
pkgrel=0
pkgdesc="Simple, fast, user-friendly alternative to find"
url="https://github.com/sharkdp/fd"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust/cargo
+# s390x: fails to build nix crate
+arch="all !s390x"
license="MIT Apache-2.0"
-makedepends="cargo"
+makedepends="cargo cargo-auditable"
checkdepends="coreutils"
options="net"
subpackages="
@@ -16,18 +17,22 @@ subpackages="
$pkgname-fish-completion
$pkgname-zsh-completion
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/fd/archive/v$pkgver.tar.gz
- minimize-size.patch
- "
+source="https://github.com/sharkdp/fd/archive/v$pkgver/fd-$pkgver.tar.gz"
+
+export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
prepare() {
default_prepare
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build --frozen --release
+ cargo auditable build --frozen --release
+ make completions
+
+ # Rebuild without completions (-0.9 MiB).
+ cargo auditable build --frozen --release --no-default-features --features use-jemalloc
}
check() {
@@ -35,19 +40,15 @@ check() {
}
package() {
- cargo install --frozen --offline --path . --root="$pkgdir"/usr
- rm "$pkgdir"/usr/.crates*
+ install -D -m755 target/release/$pkgname -t "$pkgdir"/usr/bin/
- install -Dm644 doc/fd.1 "$pkgdir"/usr/share/man/man1/fd.1
+ install -D -m644 doc/fd.1 -t "$pkgdir"/usr/share/man/man1/
- find "$builddir"/target/release/build/fd-find-* -type f -iname fd.bash \
- -exec install -Dm644 '{}' "$pkgdir"/usr/share/bash-completion/completions/fd \;
- find "$builddir"/target/release/build/fd-find-* -type f -iname fd.fish \
- -exec install -Dm644 '{}' "$pkgdir"/usr/share/fish/completions/fd.fish \;
- install -Dm644 "$builddir"/contrib/completion/_fd "$pkgdir"/usr/share/zsh/site-functions/_fd
+ install -D -m644 autocomplete/fd.bash "$pkgdir"/usr/share/bash-completion/completions/fd
+ install -D -m644 autocomplete/fd.fish "$pkgdir"/usr/share/fish/vendor_completions.d/fd.fish
+ install -D -m644 autocomplete/_fd "$pkgdir"/usr/share/zsh/site-functions/_fd
}
sha512sums="
-467d8cb66398d247e0849228cfe7ebf70f8a7758e126a048f7f34dcd45b0d69d3ff4afc903092dc7d17f42c7b9029e92e88acfc1cbe282857a733a355804bc1c fd-8.4.0.tar.gz
-5f5f1dff80a31cbd532ca220ea399436924fedeef418f84bf6bf715a76ac8c456093fe6f8409f182fe5c94741dd7916d85b4fe3b7106e287a481ab863672ed3b minimize-size.patch
+e992db9170884c5c426d51ba06a0684b000c65df3fae392fe9ffb3555b94f1d0cfde9b5ae01da37508a1b11bc75b023534db380c992cb4ccf17084d27ec87c84 fd-9.0.0.tar.gz
"