aboutsummaryrefslogtreecommitdiffstats
path: root/community/feedbackd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/feedbackd/APKBUILD')
-rw-r--r--community/feedbackd/APKBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/community/feedbackd/APKBUILD b/community/feedbackd/APKBUILD
index f04d4330abf..c6df934152d 100644
--- a/community/feedbackd/APKBUILD
+++ b/community/feedbackd/APKBUILD
@@ -1,29 +1,38 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/phosh <newbyte@postmarketos.org>
pkgname=feedbackd
-pkgver=0_git20210426
-pkgrel=0
-pkgdesc="A daemon to provide haptic (and later more) feedback on events"
+pkgver=0.2.1
+pkgrel=2
+pkgdesc="Daemon to provide haptic, LED, and audio feedback triggered by application events"
url="https://source.puri.sm/Librem5/feedbackd"
arch="all"
license="GPL-3.0-or-later"
depends="dbus feedbackd-device-themes"
-makedepends="meson glib-dev gsound-dev libgudev-dev json-glib-dev gtk-doc
- vala gobject-introspection-dev"
+makedepends="
+ gi-docgen
+ glib-dev
+ gobject-introspection-dev
+ gsound-dev
+ gtk-doc
+ json-glib-dev
+ libgudev-dev
+ meson
+ vala
+ "
subpackages="$pkgname-dev $pkgname-doc"
-source="https://source.puri.sm/Librem5/feedbackd/-/archive/v0.0.0+${pkgver#0_}/feedbackd-v0.0.0+${pkgver#0_}.tar.gz"
-builddir="$srcdir/$pkgname-v0.0.0+${pkgver#0_}"
+source="https://storage.puri.sm/releases/feedbackd/feedbackd-$pkgver.tar.xz"
install="$pkgname.pre-install $pkgname.pre-upgrade"
build() {
abuild-meson \
+ -Db_lto=true \
-Dgtk_doc=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -32,4 +41,6 @@ package() {
"$pkgdir"/usr/lib/udev/rules.d/90-feedbackd.rules
}
-sha512sums="c56eb0f34d6b4f44a6d3e12841892b491c797a11e4911044a9e83a09ecdf9c4ca87523f0a3b56bebb6592959ddd203f79e54a9acb4cbf11d3fc8cc3365490ac0 feedbackd-v0.0.0+git20210426.tar.gz"
+sha512sums="
+80dc8ce734e4ffd1455d1f3c4ac0e7f44e9d1588e6af90e1433d7aff8ada0e6c77cb06262ff762351bca20b3ccf2d8127ade04f58d4d3a69640429a14aefcafe feedbackd-0.2.1.tar.xz
+"