aboutsummaryrefslogtreecommitdiffstats
path: root/community/feedbackd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/feedbackd/APKBUILD')
-rw-r--r--community/feedbackd/APKBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/community/feedbackd/APKBUILD b/community/feedbackd/APKBUILD
index ae7c9c05c6c..603f2a59375 100644
--- a/community/feedbackd/APKBUILD
+++ b/community/feedbackd/APKBUILD
@@ -1,29 +1,38 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=feedbackd
-pkgver=0_git20220520
-pkgrel=0
-pkgdesc="A daemon to provide haptic (and later more) feedback on events"
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Daemon to provide haptic, LED, and audio feedback triggered by application events"
url="https://source.puri.sm/Librem5/feedbackd"
arch="all"
license="GPL-3.0-or-later"
depends="dbus feedbackd-device-themes"
-makedepends="meson glib-dev gsound-dev libgudev-dev json-glib-dev gtk-doc
- vala gobject-introspection-dev"
+makedepends="
+ gi-docgen
+ glib-dev
+ gobject-introspection-dev
+ gsound-dev
+ gtk-doc
+ json-glib-dev
+ libgudev-dev
+ meson
+ vala
+ "
subpackages="$pkgname-dev $pkgname-doc"
-source="https://source.puri.sm/Librem5/feedbackd/-/archive/v0.0.0+${pkgver#0_}/feedbackd-v0.0.0+${pkgver#0_}.tar.gz"
-builddir="$srcdir/$pkgname-v0.0.0+${pkgver#0_}"
+source="https://storage.puri.sm/releases/feedbackd/feedbackd-$pkgver.tar.xz"
install="$pkgname.pre-install $pkgname.pre-upgrade"
build() {
abuild-meson \
+ -Db_lto=true \
-Dgtk_doc=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -33,5 +42,5 @@ package() {
}
sha512sums="
-7400afec08cbc85f2251a0f56a08480dea1a50b30937bbe76e4828ac9aef1d9e3fe427887a5fde3337fa907c2f2a9ca0795ef41f4339b9624386d5d539a55e75 feedbackd-v0.0.0+git20220520.tar.gz
+80dc8ce734e4ffd1455d1f3c4ac0e7f44e9d1588e6af90e1433d7aff8ada0e6c77cb06262ff762351bca20b3ccf2d8127ade04f58d4d3a69640429a14aefcafe feedbackd-0.2.1.tar.xz
"