aboutsummaryrefslogtreecommitdiffstats
path: root/community/ffmpegthumbs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ffmpegthumbs/APKBUILD')
-rw-r--r--community/ffmpegthumbs/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/ffmpegthumbs/APKBUILD b/community/ffmpegthumbs/APKBUILD
index f2a9470e29b..5a756d48fd8 100644
--- a/community/ffmpegthumbs/APKBUILD
+++ b/community/ffmpegthumbs/APKBUILD
@@ -1,11 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ffmpegthumbs
-pkgver=21.08.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# not useful on s390x
+arch="all !s390x !armhf"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="FFmpeg-based thumbnail creator for video files"
license="GPL-2.0-or-later"
@@ -15,24 +18,24 @@ makedepends="
kconfig-dev
ki18n-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
taglib-dev
"
+_repo_url="https://invent.kde.org/multimedia/ffmpegthumbs.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/ffmpegthumbs-$pkgver.tar.xz"
-subpackages="$pkgname-lang"
-options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -40,5 +43,5 @@ package() {
}
sha512sums="
-bc12e46bd62c5517e3aef3dfbe2e97d7ad91b985acfdea2c03940d99825ca2147183f6d0f590b5879261755a9ec1c79655929e84653a0a968b50529cba9e02c9 ffmpegthumbs-21.08.2.tar.xz
+6f334707ca477533f29e2c11cbfcfad460664ad69bb4b05861f876ed752ac2314212e30948fdbcab025f81771a917d7d94b65b434335afcd9ebb3104283307ec ffmpegthumbs-24.02.1.tar.xz
"