aboutsummaryrefslogtreecommitdiffstats
path: root/community/ffmpegthumbs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ffmpegthumbs/APKBUILD')
-rw-r--r--community/ffmpegthumbs/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/ffmpegthumbs/APKBUILD b/community/ffmpegthumbs/APKBUILD
index a4390492774..9117ad4e5e7 100644
--- a/community/ffmpegthumbs/APKBUILD
+++ b/community/ffmpegthumbs/APKBUILD
@@ -1,29 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ffmpegthumbs
-pkgver=22.04.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by kio
-arch="all !armhf !s390x !riscv64"
+# not useful on s390x
+arch="all !s390x !armhf"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="FFmpeg-based thumbnail creator for video files"
license="GPL-2.0-or-later"
makedepends="
extra-cmake-modules
- ffmpeg4-dev
+ ffmpeg-dev
kconfig-dev
ki18n-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
taglib-dev
"
+_repo_url="https://invent.kde.org/multimedia/ffmpegthumbs.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/ffmpegthumbs-$pkgver.tar.xz"
-options="!check" # No tests
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -31,8 +35,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -40,5 +43,5 @@ package() {
}
sha512sums="
-c5519966ecd5aa589e0f31963fa0ba91a1067bbdcd699d37b7671bbcbdcb8068dbb7b8309eb1883c80dd7938b4f57fd96b47d27fb6933a0218218bf6a1611f93 ffmpegthumbs-22.04.1.tar.xz
+4032c489c97231ff9a0d68b2a1ae35ed886962e99d12df7781d4f1f6408a6e2f1fdf5e15cce3b639b2e839467265c6ba6a2133b10cd7ae5225682db710bbb1d7 ffmpegthumbs-24.02.2.tar.xz
"