aboutsummaryrefslogtreecommitdiffstats
path: root/community/ffmpegthumbs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ffmpegthumbs/APKBUILD')
-rw-r--r--community/ffmpegthumbs/APKBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/community/ffmpegthumbs/APKBUILD b/community/ffmpegthumbs/APKBUILD
index 470a26befbd..9117ad4e5e7 100644
--- a/community/ffmpegthumbs/APKBUILD
+++ b/community/ffmpegthumbs/APKBUILD
@@ -1,11 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ffmpegthumbs
-pkgver=20.12.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 blocked by kio
-arch="all !armhf !s390x !mips64"
+# not useful on s390x
+arch="all !s390x !armhf"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="FFmpeg-based thumbnail creator for video files"
license="GPL-2.0-or-later"
@@ -15,28 +18,30 @@ makedepends="
kconfig-dev
ki18n-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
taglib-dev
"
+_repo_url="https://invent.kde.org/multimedia/ffmpegthumbs.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/ffmpegthumbs-$pkgver.tar.xz"
-subpackages="$pkgname-lang"
-options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="42a293c785d157548714529ce59f12f2d2458f80552b173fd21682ccfc466c8bc6ee7b271dfa899848821bd763b23d195efca21de9e01e0f7ad0356418e00263 ffmpegthumbs-20.12.2.tar.xz"
+sha512sums="
+4032c489c97231ff9a0d68b2a1ae35ed886962e99d12df7781d4f1f6408a6e2f1fdf5e15cce3b639b2e839467265c6ba6a2133b10cd7ae5225682db710bbb1d7 ffmpegthumbs-24.02.2.tar.xz
+"