aboutsummaryrefslogtreecommitdiffstats
path: root/community/file-roller/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/file-roller/APKBUILD')
-rw-r--r--community/file-roller/APKBUILD40
1 files changed, 31 insertions, 9 deletions
diff --git a/community/file-roller/APKBUILD b/community/file-roller/APKBUILD
index 072094d81b9..f25874f687c 100644
--- a/community/file-roller/APKBUILD
+++ b/community/file-roller/APKBUILD
@@ -1,32 +1,54 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=file-roller
-pkgver=3.40.0
+pkgver=43.1
pkgrel=0
pkgdesc="File Roller is an archive manager for the GNOME desktop "
url="https://wiki.gnome.org/Apps/FileRoller"
-arch="all !s390x !mips !mips64" # blocked by nautilus-dev
+# s390x blocked by mozjs91 -> nautilus-dev
+arch="all !s390x"
license="GPL-2.0-or-later"
depends="cpio"
-makedepends="meson glib-dev gtk+3.0-dev json-glib-dev libnotify-dev libarchive-dev
- itstool nautilus-dev"
-subpackages="$pkgname-lang"
+depends_doc="yelp"
+makedepends="
+ desktop-file-utils
+ glib-dev
+ gtk+3.0-dev
+ itstool
+ json-glib-dev
+ libarchive-dev
+ libhandy1-dev
+ libnotify-dev
+ libportal-dev
+ meson
+ nautilus-dev
+ "
+subpackages="$pkgname-lang $pkgname-doc $pkgname-nautilus"
source="https://download.gnome.org/sources/file-roller/${pkgver%.*}/file-roller-$pkgver.tar.xz"
build() {
abuild-meson \
+ -Db_lto=true \
-Dpackagekit=false \
-Dcpio=/usr/bin/cpio \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="224dbe4f4358aa62589d084d67244ad8d65d718f9b6adf708ba1425b38fca68e08b07a6163f66d95c6acfd164b6062939cfeb27873ea41353e0551e322b0eb26 file-roller-3.40.0.tar.xz"
+nautilus() {
+ pkgdesc="File Roller nautilus extension"
+ install_if="$pkgname=$pkgver-r$pkgrel nautilus",
+ amove usr/lib/nautilus/extensions-4/libnautilus-fileroller.so
+}
+
+sha512sums="
+444467c2bf9c2aa885fad5119069232ea92872c1f08fc7cd517e2e64faef924f0b4a9195acbe042e535588ccd86b5147afa041f9ea355f480507c3743a2bb934 file-roller-43.1.tar.xz
+"