aboutsummaryrefslogtreecommitdiffstats
path: root/community/filecheck/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/filecheck/APKBUILD')
-rw-r--r--community/filecheck/APKBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/community/filecheck/APKBUILD b/community/filecheck/APKBUILD
index d3f7851150f..3ab595e02f0 100644
--- a/community/filecheck/APKBUILD
+++ b/community/filecheck/APKBUILD
@@ -1,39 +1,36 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=filecheck
-pkgver=0.0.22
-pkgrel=0
+pkgver=0.0.24
+pkgrel=1
pkgdesc="Attempt to reimplement LLVM's FileCheck using Python"
url="https://github.com/mull-project/FileCheck.py"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="py3-poetry-core py3-build py3-installer"
+makedepends="py3-hatchling py3-gpep517 py3-installer"
checkdepends="py3-pytest"
-source="https://github.com/mull-project/FileCheck.py/archive/v$pkgver/filecheck-$pkgver.tar.gz
- poetry-core.patch
- "
+subpackages="$pkgname-pyc"
+source="https://github.com/mull-project/FileCheck.py/archive/v$pkgver/filecheck-$pkgver.tar.gz"
builddir="$srcdir/FileCheck.py-$pkgver"
build() {
- # poetry-core excludes files specified in .gitignore
- # fixed by setting GIT_DIR to somewhere that isn't a git repository
- GIT_DIR="$builddir" python3 -m build \
- --no-isolation \
- --wheel \
- --skip-dependency-check
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
python3 -m installer -d "$pkgdir" \
- dist/filecheck-$pkgver-py3-none-any.whl
+ .dist/*.whl
}
sha512sums="
-f7d5385c396ef379376668ffd9359ad6203be2f56c807125e3c63e7664ccccff0045bc1c9fffe2c30e8cc91f028d6a386dbb19e4eaa5f3a35bb62bd98d278b90 filecheck-0.0.22.tar.gz
-a673878a604201d6a8b664b1baabb7f10612bf446a6d93823847c220d9603f68c0d635ec7645d7ca45ed5f4ea2c7a38dc87fa247d4e646d809b47a00a4ce04bb poetry-core.patch
+ed3b42afc3ba55ab7bb19df45732fb092048a93f02fb0f98e24085a7968e5292ba597343aaf26b008a5541f4b59ec0dd662bb2c12e2695a60bfad60cd23bb60c filecheck-0.0.24.tar.gz
"