aboutsummaryrefslogtreecommitdiffstats
path: root/community/filecheck/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/filecheck/APKBUILD')
-rw-r--r--community/filecheck/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/filecheck/APKBUILD b/community/filecheck/APKBUILD
index d2e6f118de4..3ab595e02f0 100644
--- a/community/filecheck/APKBUILD
+++ b/community/filecheck/APKBUILD
@@ -1,33 +1,36 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=filecheck
-pkgver=0.0.21
+pkgver=0.0.24
pkgrel=1
pkgdesc="Attempt to reimplement LLVM's FileCheck using Python"
url="https://github.com/mull-project/FileCheck.py"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="py3-setuptools poetry py3-installer"
+makedepends="py3-hatchling py3-gpep517 py3-installer"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://github.com/mull-project/FileCheck.py/archive/v$pkgver/filecheck-$pkgver.tar.gz"
builddir="$srcdir/FileCheck.py-$pkgver"
build() {
- # poetry-core excludes files specified in .gitignore
- # fixed by setting GIT_DIR to somewhere that isn't a git repository
- GIT_DIR="$builddir" poetry build -f wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
python3 -m installer -d "$pkgdir" \
- dist/filecheck-$pkgver-py3-none-any.whl
+ .dist/*.whl
}
sha512sums="
-9b21fd1bbfc92d077280d4c68a5dbdabd3644fd47a840d640ba548e49c701184d5c6823e46550774d6c619b780e7bed7174e3be2d57579c7ffed80b119b76c00 filecheck-0.0.21.tar.gz
+ed3b42afc3ba55ab7bb19df45732fb092048a93f02fb0f98e24085a7968e5292ba597343aaf26b008a5541f4b59ec0dd662bb2c12e2695a60bfad60cd23bb60c filecheck-0.0.24.tar.gz
"