aboutsummaryrefslogtreecommitdiffstats
path: root/community/filelight/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/filelight/APKBUILD')
-rw-r--r--community/filelight/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/community/filelight/APKBUILD b/community/filelight/APKBUILD
index c4125eae393..cf79e3e9516 100644
--- a/community/filelight/APKBUILD
+++ b/community/filelight/APKBUILD
@@ -1,37 +1,42 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=filelight
-pkgver=21.04.3
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/filelight"
pkgdesc="An application to visualize the disk usage on your computer"
license="(GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
+ kdeclarative-dev
kdoctools-dev
ki18n-dev
kio-dev
+ kirigami-addons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
+checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/utilities/filelight.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/filelight-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+subpackages="$pkgname-dbg $pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -39,5 +44,5 @@ package() {
}
sha512sums="
-7f239b0bbef95a111407d85cd7da6f9523a3b12e8ab13a29b4a7f661315e47866bf04a9863464124edd14f4e35b4d45e23cfafe059bd325b7f9f6ed3fc416a7d filelight-21.04.3.tar.xz
+8e959e875af535b876e5f4bac3e127e110e5eb6a217aa3bfe4ba7eaebba2aff10e1a6a070ec61a3615ab4146a7188671e7010243f42a4d203ba84b1c2c7ea0d3 filelight-24.02.1.tar.xz
"