aboutsummaryrefslogtreecommitdiffstats
path: root/community/filelight/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/filelight/APKBUILD')
-rw-r--r--community/filelight/APKBUILD33
1 files changed, 20 insertions, 13 deletions
diff --git a/community/filelight/APKBUILD b/community/filelight/APKBUILD
index 630a8d847bd..41808f6e030 100644
--- a/community/filelight/APKBUILD
+++ b/community/filelight/APKBUILD
@@ -1,41 +1,48 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=filelight
-pkgver=20.12.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x blocked by kxmlgui
-arch="all !armhf !s390x !mips64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/filelight"
pkgdesc="An application to visualize the disk usage on your computer"
license="(GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
+ kdeclarative-dev
kdoctools-dev
ki18n-dev
kio-dev
+ kirigami-addons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
+checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/utilities/filelight.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/filelight-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+subpackages="$pkgname-dbg $pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="b43f4b1a31898860b8c128a9b1117e490cdbacced4e36cfaac52921ef1697551592deeeea014b2723080074c6c65ac47e356276a35a0cfd034a989904876c72d filelight-20.12.2.tar.xz"
+sha512sums="
+4f845db966bd329484e5bc9a6f935e5672efa730a01577a0a6163b53b96d261f2590283ccb699497ae1d6605b039c1ec632ef2adebba64f361c0dd05b6e619a6 filelight-24.02.2.tar.xz
+"