aboutsummaryrefslogtreecommitdiffstats
path: root/community/filezilla/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/filezilla/APKBUILD')
-rw-r--r--community/filezilla/APKBUILD52
1 files changed, 44 insertions, 8 deletions
diff --git a/community/filezilla/APKBUILD b/community/filezilla/APKBUILD
index 74e65b8d233..023f2c52b89 100644
--- a/community/filezilla/APKBUILD
+++ b/community/filezilla/APKBUILD
@@ -1,24 +1,58 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=filezilla
-pkgver=3.46.3
+pkgver=3.66.5
pkgrel=0
pkgdesc="FTP Client"
-url="https://filezilla-project.org"
+url="https://filezilla-project.org/"
arch="all"
license="GPL-2.0-or-later"
-makedepends="gnutls-dev gtk+2.0-dev libfilezilla-dev>=0.18.0 libidn-dev
- pugixml-dev sqlite-dev wxgtk3-dev xdg-utils"
+makedepends="
+ autoconf
+ automake
+ boost-dev
+ gnutls-dev
+ gtk+3.0-dev
+ libfilezilla-dev
+ libidn-dev
+ libtool
+ pugixml-dev
+ sqlite-dev
+ wxwidgets-dev
+ xdg-utils
+ "
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.filezilla-project.org/client/FileZilla_${pkgver}_src.tar.bz2"
+source="https://download.filezilla-project.org/client/FileZilla_${pkgver}_src.tar.xz"
+
+case "$CARCH" in
+s390x) options="$options !check";; # ratelimit_test fails
+esac
+
+# secfixes:
+# 3.66.4-r0:
+# - CVE-2023-48795
+
+prepare() {
+ default_prepare
+
+ # patched autoconf
+ NOCONFIGURE=1 autoreconf -vif
+}
build() {
+ case "$CARCH" in
+ x86)
+ # fails to build otherwise
+ export CFLAGS="$CFLAGS -D_FORCE_SOFTWARE_SHA"
+ ;;
+ esac
+ CFLAGS="$CFLAGS -flto=auto" \
+ CXXFLAGS="$CXXFLAGS -flto=auto" \
./configure \
- --prefix=/usr \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--without-dbus \
- --with-wx-config=/usr/bin/wx-config-gtk3 \
--disable-manualupdatecheck \
--disable-autoupdatecheck
make
@@ -32,4 +66,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="35b61c3bfd1d40848e7846b4533da8844df0e4873cb89286b90330cbc29dffeff96fcab10aec908a08d9129198bb2d80df8f223d8ebc1a0863a4083cb06abffc FileZilla_3.46.3_src.tar.bz2"
+sha512sums="
+b250e65894a3e8c8eb0eac25b3ffa5cd1348df2a38b1e6fa5eb735fff1945dbeb1fbcfe10a8188c260e9fbeaeb78322cb8aa56f6386fd39803421d01bbc8b2dd FileZilla_3.66.5_src.tar.xz
+"