aboutsummaryrefslogtreecommitdiffstats
path: root/community/filezilla
diff options
context:
space:
mode:
Diffstat (limited to 'community/filezilla')
-rw-r--r--community/filezilla/APKBUILD57
-rw-r--r--community/filezilla/missing-list-include.patch13
2 files changed, 43 insertions, 27 deletions
diff --git a/community/filezilla/APKBUILD b/community/filezilla/APKBUILD
index 7046dbd778a..9da54c39007 100644
--- a/community/filezilla/APKBUILD
+++ b/community/filezilla/APKBUILD
@@ -1,30 +1,58 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=filezilla
-pkgver=3.51.0
+pkgver=3.66.5
pkgrel=1
pkgdesc="FTP Client"
-url="https://filezilla-project.org"
-arch="all !mips !mips64"
+url="https://filezilla-project.org/"
+arch="all"
license="GPL-2.0-or-later"
-makedepends="gnutls-dev gtk+2.0-dev libfilezilla-dev>=0.18.0 libidn-dev
- pugixml-dev sqlite-dev wxgtk3-dev xdg-utils"
+makedepends="
+ autoconf
+ automake
+ boost-dev
+ gnutls-dev
+ gtk+3.0-dev
+ libfilezilla-dev
+ libidn-dev
+ libtool
+ pugixml-dev
+ sqlite-dev
+ wxwidgets-dev
+ xdg-utils
+ "
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.filezilla-project.org/client/FileZilla_${pkgver}_src.tar.bz2
- missing-list-include.patch"
+source="https://download.filezilla-project.org/client/FileZilla_${pkgver}_src.tar.xz"
+
case "$CARCH" in
- s390x)
- options="!check" # ratelimit_test fails
+s390x) options="$options !check";; # ratelimit_test fails
esac
+# secfixes:
+# 3.66.4-r0:
+# - CVE-2023-48795
+
+prepare() {
+ default_prepare
+
+ # patched autoconf
+ NOCONFIGURE=1 autoreconf -vif
+}
+
build() {
- export CXXFLAGS="$CXXFLAGS -include assert.h"
+ case "$CARCH" in
+ x86)
+ # fails to build otherwise
+ export CFLAGS="$CFLAGS -D_FORCE_SOFTWARE_SHA"
+ ;;
+ esac
+ CFLAGS="$CFLAGS -flto=auto" \
+ CXXFLAGS="$CXXFLAGS -flto=auto" \
./configure \
- --prefix=/usr \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--without-dbus \
- --with-wx-config=/usr/bin/wx-config-gtk3 \
--disable-manualupdatecheck \
--disable-autoupdatecheck
make
@@ -38,5 +66,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="b5e0f80b61eb168b41f7582bf10bf0067da76aec3165ffe13819e20eb842ffc0fb12b01c54843b3ec4e7355111c36be249db3526e2ea2eaa77ba4274ffa03e93 FileZilla_3.51.0_src.tar.bz2
-6280da4f1c359be7d49e8b590f036ddf1220ce6145fbba6c789c89d444a2a85d283275e402d996a6d28e9d5129f646b7920005d5d71faa4a80f0c734133c48a1 missing-list-include.patch"
+sha512sums="
+b250e65894a3e8c8eb0eac25b3ffa5cd1348df2a38b1e6fa5eb735fff1945dbeb1fbcfe10a8188c260e9fbeaeb78322cb8aa56f6386fd39803421d01bbc8b2dd FileZilla_3.66.5_src.tar.xz
+"
diff --git a/community/filezilla/missing-list-include.patch b/community/filezilla/missing-list-include.patch
deleted file mode 100644
index 29dd00e2075..00000000000
--- a/community/filezilla/missing-list-include.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/interface/Mainfrm.h b/src/interface/Mainfrm.h
-index 0641ff5..5da2840 100644
---- a/src/interface/Mainfrm.h
-+++ b/src/interface/Mainfrm.h
-@@ -8,6 +8,8 @@
-
- #include <wx/timer.h>
-
-+#include <list>
-+
- #ifndef __WXMAC__
- #include <wx/taskbar.h>
- #endif