aboutsummaryrefslogtreecommitdiffstats
path: root/community/firefox-esr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/firefox-esr/APKBUILD')
-rw-r--r--community/firefox-esr/APKBUILD355
1 files changed, 282 insertions, 73 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index 1687ba42cb9..5c3b8cd541f 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -1,25 +1,30 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=firefox-esr
-pkgver=102.1.0
+pkgver=115.10.0
# Date of release, YY-MM-DD for metainfo file (see package())
-_releasedate=2022-07-26
-pkgrel=2
+# https://www.mozilla.org/firefox/organizations/notes/
+_releasedate=2024-03-22
+pkgrel=0
pkgdesc="Firefox web browser - Extended Support Release"
url="https://www.mozilla.org/en-US/firefox/organizations/"
# s390x and riscv64: blocked by rust and cargo
# armhf: build failure on armhf due to wasm
arch="x86_64 armv7 aarch64 x86 ppc64le"
license="GPL-3.0-only AND LGPL-2.1-only AND LGPL-3.0-only AND MPL-2.0"
-depends="ffmpeg-libs"
+install="$pkgname.post-upgrade"
+depends="
+ ffmpeg-libavcodec
+ "
makedepends="
alsa-lib-dev
automake
bsd-compat-headers
cargo
- cbindgen>=0.18.0
- clang-dev
+ cbindgen
+ clang
+ clang-libclang
dbus-glib-dev
gettext
gtk+3.0-dev
@@ -27,7 +32,6 @@ makedepends="
icu-dev>=69.1
libevent-dev
libffi-dev
- libidl-dev
libjpeg-turbo-dev
libnotify-dev
libogg-dev
@@ -45,8 +49,7 @@ makedepends="
nasm
nodejs
nspr-dev
- nss-dev>=3.44.1
- nss-static
+ nss-dev
pipewire-dev
pulseaudio-dev
py3-psutil
@@ -55,41 +58,220 @@ makedepends="
sed
wasi-sdk
wireless-tools-dev
- yasm
zip
"
-
+subpackages="$pkgname-intl"
source="https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz
- allow-custom-rust-vendor.patch
- avoid-redefinition.patch
- cbindgen-0.24.patch
+ audio-lfs64.patch
disable-moz-stackwalk.patch
- disable-neon-in-aom.patch
esr-metainfo.patch
fix-fortify-system-wrappers.patch
fix-rust-target.patch
fix-webrtc-glibcisms.patch
- mallinfo.patch
+ icu74.patch
+ lfs64.patch
+ no-ccache-stats.patch
+ ppc-musttail.patch
+ ppc-webrtc.patch
python-deps.patch
- rust-1.63.patch
+ rust-lto-thin.patch
sandbox-fork.patch
sandbox-largefile.patch
sandbox-sched_setscheduler.patch
stab.h
- firefox-safe.desktop
firefox.desktop
+ mozilla-location.keys
vendor-prefs.js
"
builddir="$srcdir/firefox-$pkgver"
-_mozappdir=/usr/lib/firefox
+_mozappdir=/usr/lib/firefox-esr
# help our shared-object scanner to find the libs
ldpath="$_mozappdir"
# secfixes:
+# 115.6.0-r0:
+# - CVE-2023-6856
+# - CVE-2023-6865
+# - CVE-2023-6857
+# - CVE-2023-6858
+# - CVE-2023-6859
+# - CVE-2023-6860
+# - CVE-2023-6867
+# - CVE-2023-6861
+# - CVE-2023-6862
+# - CVE-2023-6863
+# - CVE-2023-6864
+# 115.5.0-r0:
+# - CVE-2023-6204
+# - CVE-2023-6205
+# - CVE-2023-6206
+# - CVE-2023-6207
+# - CVE-2023-6208
+# - CVE-2023-6209
+# - CVE-2023-6212
+# 115.4.0-r0:
+# - CVE-2023-5721
+# - CVE-2023-5732
+# - CVE-2023-5724
+# - CVE-2023-5725
+# - CVE-2023-5726
+# - CVE-2023-5727
+# - CVE-2023-5728
+# - CVE-2023-5730
+# 115.3.1-r0:
+# - CVE-2023-5217
+# 115.3.0-r0:
+# - CVE-2023-5168
+# - CVE-2023-5169
+# - CVE-2023-5171
+# - CVE-2023-5174
+# - CVE-2023-5176
+# 115.2.1-r0:
+# - CVE-2023-4863
+# 115.2.0-r0:
+# - CVE-2023-4573
+# - CVE-2023-4574
+# - CVE-2023-4575
+# - CVE-2023-4576
+# - CVE-2023-4577
+# - CVE-2023-4051
+# - CVE-2023-4578
+# - CVE-2023-4053
+# - CVE-2023-4580
+# - CVE-2023-4581
+# - CVE-2023-4582
+# - CVE-2023-4583
+# - CVE-2023-4584
+# - CVE-2023-4585
+# 115.1.0-r0:
+# - CVE-2023-4045
+# - CVE-2023-4046
+# - CVE-2023-4047
+# - CVE-2023-4048
+# - CVE-2023-4049
+# - CVE-2023-4050
+# - CVE-2023-4052
+# - CVE-2023-4054
+# - CVE-2023-4055
+# - CVE-2023-4056
+# - CVE-2023-4057
+# 115.0.2-r0:
+# - CVE-2023-3600
+# 115.0-r0:
+# - CVE-2023-3482
+# - CVE-2023-37201
+# - CVE-2023-37202
+# - CVE-2023-37203
+# - CVE-2023-37204
+# - CVE-2023-37205
+# - CVE-2023-37206
+# - CVE-2023-37207
+# - CVE-2023-37208
+# - CVE-2023-37209
+# - CVE-2023-37210
+# - CVE-2023-37211
+# - CVE-2023-37212
+# 102.12.0-r0:
+# - CVE-2023-34414
+# - CVE-2023-34416
+# 102.11.0-r0:
+# - CVE-2023-32205
+# - CVE-2023-32206
+# - CVE-2023-32207
+# - CVE-2023-32211
+# - CVE-2023-32212
+# - CVE-2023-32213
+# - CVE-2023-32214
+# - CVE-2023-32215
+# 102.10.0-r0:
+# - CVE-2023-29531
+# - CVE-2023-29532
+# - CVE-2023-29533
+# - CVE-2023-1999
+# - CVE-2023-29535
+# - CVE-2023-29536
+# - CVE-2023-29539
+# - CVE-2023-29541
+# - CVE-2023-29542
+# - CVE-2023-29545
+# - CVE-2023-1945
+# - CVE-2023-29548
+# - CVE-2023-29550
+# 102.9.0-r0:
+# - CVE-2023-25751
+# - CVE-2023-28164
+# - CVE-2023-28162
+# - CVE-2023-25752
+# - CVE-2023-28163
+# - CVE-2023-28176
+# 102.8.0-r0:
+# - CVE-2023-25728
+# - CVE-2023-25730
+# - CVE-2023-0767
+# - CVE-2023-25735
+# - CVE-2023-25737
+# - CVE-2023-25738
+# - CVE-2023-25739
+# - CVE-2023-25729
+# - CVE-2023-25732
+# - CVE-2023-25734
+# - CVE-2023-25742
+# - CVE-2023-25744
+# - CVE-2023-25746
+# 102.7.0-r0:
+# - CVE-2022-46871
+# - CVE-2023-23598
+# - CVE-2023-23599
+# - CVE-2023-23601
+# - CVE-2023-23602
+# - CVE-2022-46877
+# - CVE-2023-23603
+# - CVE-2023-23605
+# 102.6.0-r0:
+# - CVE-2022-46880
+# - CVE-2022-46872
+# - CVE-2022-46881
+# - CVE-2022-46874
+# - CVE-2022-46875
+# - CVE-2022-46882
+# - CVE-2022-46878
+# 102.5.0-r0:
+# - CVE-2022-45403
+# - CVE-2022-45404
+# - CVE-2022-45405
+# - CVE-2022-45406
+# - CVE-2022-45408
+# - CVE-2022-45409
+# - CVE-2022-45410
+# - CVE-2022-45411
+# - CVE-2022-45412
+# - CVE-2022-45416
+# - CVE-2022-45418
+# - CVE-2022-45420
+# - CVE-2022-45421
+# 102.4.0-r0:
+# - CVE-2022-42927
+# - CVE-2022-42928
+# - CVE-2022-42929
+# - CVE-2022-42932
+# 102.3.0-r0:
+# - CVE-2022-3266
+# - CVE-2022-40959
+# - CVE-2022-40960
+# - CVE-2022-40958
+# - CVE-2022-40956
+# - CVE-2022-40957
+# - CVE-2022-40962
+# 102.2.0-r0:
+# - CVE-2022-38472
+# - CVE-2022-38473
+# - CVE-2022-38476
+# - CVE-2022-38477
+# - CVE-2022-38478
# 102.1.0-r0:
# - CVE-2022-2505
# - CVE-2022-36314
@@ -431,7 +613,8 @@ export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
export USE_SHORT_LIBNAME=1
export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
-export MOZ_APP_REMOTINGNAME=firefox
+export MOZ_APP_PROFILE="mozilla/firefox"
+export MOZ_APP_REMOTINGNAME=firefox-esr
export MOZBUILD_STATE_PATH="$srcdir"/mozbuild
# disable desktop notifications
export MOZ_NOSPAM=1
@@ -445,39 +628,30 @@ export CXX="clang++"
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,$_mozappdir"
-# LLVM OOM dodge
-# TODO: why does this fail with more than 4 threads and so much memory?
-export LDFLAGS="$LDFLAGS -Wl,--thinlto-jobs=4"
-
# let firefox do this itself.
unset CARGO_PROFILE_RELEASE_OPT_LEVEL
unset CARGO_PROFILE_RELEASE_LTO
+export CFLAGS="${CFLAGS/-fstack-clash-protection/} -g0 -O2"
+export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection/} -g0 -O2 -Wno-deprecated-builtins -Wno-deprecated-declarations"
+
prepare() {
default_prepare
cp "$srcdir"/stab.h toolkit/crashreporter/google-breakpad/src/
_clear_vendor_checksums audio_thread_priority
- _clear_vendor_checksums target-lexicon-0.9.0
- _clear_vendor_checksums packed_simd_2
- case "$CARCH" in
- aarch64|arm*|x86*)
- # disable-elf-hack: exists only on aarch64, arm*, x86, x86_64
- local arch_config="ac_add_options --disable-elf-hack"
- ;;
- esac
+ base64 -d "$srcdir"/mozilla-location.keys > "$builddir"/mozilla-api-key
# webrtc does not build on these
case "$CARCH" in
- armv7|ppc64le)
+ ppc64le)
local webrtc_config="ac_add_options --disable-webrtc"
;;
esac
-
- # FF doesn't have SIMD available on armhf/v7
case "$CARCH" in
- arm*)
+ armv7)
+ # broken here
local rust_simd="ac_add_options --disable-rust-simd"
;;
*)
@@ -485,16 +659,10 @@ prepare() {
;;
esac
- # disable debug on 32-bit (takes too much link memory)
case "$CARCH" in
- arm*|x86)
- local low_mem_flags="
- ac_add_options --disable-debug-symbols
- ac_add_options --disable-debug
- "
- # hardcoded in the file
- sed -i 's|debug_info = "2"|debug_info = "0"|' \
- ./build/moz.configure/toolchain.configure
+ aarch64|arm*|x86*)
+ # disable-elf-hack: exists only on aarch64, arm*, x86, x86_64
+ local arch_config="ac_add_options --disable-elf-hack"
;;
esac
@@ -513,6 +681,8 @@ prepare() {
ac_add_options --disable-bootstrap
ac_add_options --disable-cargo-incremental
ac_add_options --disable-crashreporter
+ ac_add_options --disable-debug
+ ac_add_options --disable-debug-symbols
ac_add_options --disable-install-strip
ac_add_options --disable-jemalloc
ac_add_options --disable-strip
@@ -526,10 +696,9 @@ prepare() {
ac_add_options --enable-ffmpeg
ac_add_options --enable-hardening
ac_add_options --enable-linker=lld
- ac_add_options --enable-lto=cross
ac_add_options --enable-necko-wifi
ac_add_options --enable-official-branding
- ac_add_options --enable-optimize="$CFLAGS -O2"
+ ac_add_options --enable-optimize="$CFLAGS"
ac_add_options --enable-pulseaudio
ac_add_options --enable-release
ac_add_options --enable-update-channel=release
@@ -548,17 +717,26 @@ prepare() {
ac_add_options --with-system-zlib
# misc
+ ac_add_options --allow-addon-sideload
ac_add_options --prefix=/usr
+ ac_add_options --with-app-name=firefox-esr
ac_add_options --with-distribution-id=org.alpinelinux
ac_add_options --with-libclang-path=/usr/lib
ac_add_options --with-unsigned-addon-scopes=app,system
ac_add_options --with-wasi-sysroot=/usr/share/wasi-sysroot
+ ac_add_options --host=$CHOST
+ ac_add_options --target=$CTARGET
# objdir
mk_add_options MOZ_OBJDIR="$builddir/obj"
+ mk_add_options RUSTFLAGS="$RUSTFLAGS"
+
+ # keys
+ # these are for alpine linux use only
+ ac_add_options --with-mozilla-api-keyfile="$builddir/mozilla-api-key"
+
$arch_config
- $low_mem_flags
$rust_simd
$sandbox
$webrtc_config
@@ -573,6 +751,31 @@ build() {
# for lto
ulimit -n 4096
+ # can't be set here and fail
+ unset RUSTFLAGS
+
+ local thinlto_jobs=${JOBS:-1}
+
+ case "$CARCH" in
+ # on this platforms, lld seems to not utilise >1 threads for thinlto for some reason.
+ # at the same time, having more than 8 also crashes lld for firefox buildsystems (why?).
+ aarch64)
+ if [ $thinlto_jobs -gt 8 ]; then
+ thinlto_jobs=8
+ fi
+ ;;
+ esac
+
+ export LDFLAGS="$LDFLAGS -Wl,--thinlto-jobs=$thinlto_jobs"
+
+ case "$CARCH" in
+ # lto for 64-bit systems only
+ aarch64|x86_64|ppc64le)
+ cat > .mozconfig base-mozconfig <<-EOF
+ ac_add_options --enable-lto=cross
+ EOF
+ esac
+
./mach build
}
@@ -584,20 +787,18 @@ package() {
local i=${_png%.png}
i=${i##*/default}
install -Dm644 "$_png" \
- "$pkgdir"/usr/share/icons/hicolor/"$i"x"$i"/apps/firefox.png
+ "$pkgdir"/usr/share/icons/hicolor/"$i"x"$i"/apps/firefox-esr.png
done
install -Dm644 browser/branding/official/content/about-logo.png \
- "$pkgdir"/usr/share/icons/hicolor/192x192/apps/firefox.png
+ "$pkgdir"/usr/share/icons/hicolor/192x192/apps/firefox-esr.png
install -Dm644 browser/branding/official/content/about-logo@2x.png \
- "$pkgdir"/usr/share/icons/hicolor/384x384/apps/firefox.png
+ "$pkgdir"/usr/share/icons/hicolor/384x384/apps/firefox-esr.png
install -Dm644 browser/branding/official/content/about-logo.svg \
- "$pkgdir"/usr/share/icons/hicolor/scalable/apps/firefox.svg
+ "$pkgdir"/usr/share/icons/hicolor/scalable/apps/firefox-esr.svg
install -Dm644 "$srcdir"/firefox.desktop \
- "$pkgdir"/usr/share/applications/org.mozilla.firefox.desktop
- install -Dm644 "$srcdir"/firefox-safe.desktop \
- "$pkgdir"/usr/share/applications/org.mozilla.firefox-safe.desktop
+ "$pkgdir"/usr/share/applications/firefox-esr.desktop
# install our vendor prefs
install -Dm644 "$srcdir"/vendor-prefs.js \
@@ -607,37 +808,45 @@ package() {
mkdir -p "$pkgdir"/usr/share/metainfo/
export VERSION="$pkgver"
export DATE="$_releasedate"
- envsubst < "$builddir"/taskcluster/docker/firefox-flatpak/org.mozilla.firefox.appdata.xml.in > "$pkgdir"/usr/share/metainfo/org.mozilla.firefox.appdata.xml
+ envsubst < "$builddir"/taskcluster/docker/firefox-flatpak/org.mozilla.firefox.appdata.xml.in > "$pkgdir"/usr/share/metainfo/org.mozilla.firefox-esr.appdata.xml
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- install -Dm755 /dev/stdin "$pkgdir"/usr/bin/firefox <<- EOF
+ install -Dm755 /dev/stdin "$pkgdir"/usr/bin/firefox-esr <<- EOF
#!/bin/sh
- exec $_mozappdir/firefox "\$@"
+ exec $_mozappdir/firefox-esr "\$@"
EOF
- rm "$pkgdir"/$_mozappdir/firefox-bin
- ln -sfv /usr/bin/firefox "$pkgdir"/$_mozappdir/firefox-bin
+ rm "$pkgdir"/$_mozappdir/firefox-esr-bin
+ ln -sfv /usr/bin/firefox-esr "$pkgdir"/$_mozappdir/firefox-esr-bin
+}
+
+intl() {
+ pkgdesc="$pkgname - International ICU data"
+ depends="icu-data-full"
+ install_if="$pkgname=$pkgver-r$pkgrel icu"
+ mkdir -p "$subpkgdir"
}
sha512sums="
-2505b87ce4115445568eb6b7d8af41678bd787fd07f3f79e9f0a22d90cdf752ae5d4371856cf9c56e2d9da7d5b7c3939dc2aab5753fcc017398e7d65260f6f03 firefox-102.1.0esr.source.tar.xz
-4e584621145cf8add069c6dac18e805b3274a1ee402d84e924df2341f7d3c5be261a93ef51283bacbd606f47fbdc628c4323ecc31efc5b403b8d224b18dc278f allow-custom-rust-vendor.patch
-b1cb2db3122634f66d2bae7066e76f2dcd455c464e021db4de3b0a08314df95cb667846081682db549dd2af8a00831cabe44a2420c66cdfb5e3b5fa7e6bd21d3 avoid-redefinition.patch
-3526402ccae1f0428f2e45bae8d0b2cb909ac2698bc3508b692b827839ccb21203ce414206039776f6ce946fc53e636290b7870e9886284d5e9d1e8ad050aac9 cbindgen-0.24.patch
+0626e2c68ce43f24dfc2b9216e2565537ad8781daf4195d53420e1b78d57d0f6360fbe56b0ddbedae3818546c72472c85c1ff2b208c123d32a0543e666f42b65 firefox-115.10.0esr.source.tar.xz
+3e0501ae7a650346c667dfdc0ae0ca286084f22e89ab2ac671cc0d7315673dc5b6dcb9f9882f6f39d26e9a31e57f7a0fd53d6b805e520224e22b8976850e2eb8 audio-lfs64.patch
454ea3263cabce099accbdc47aaf83be26a19f8b5a4568c01a7ef0384601cf8315efd86cd917f9c8bf419c2c845db89a905f3ff9a8eb0c8e41042e93aa96a85c disable-moz-stackwalk.patch
-55eab1a02e19a19a1ee0e36b11097ab48a44200e07e543d91469967206854f39709c7c0bc31855559528e64642d610868140e9533f1c0e3bebc953353c142fa8 disable-neon-in-aom.patch
-2e9b1d712258ba6a44401d6c41c3194fd78180b171f3b910121e23cc5299f92e0120426306973de3e6ae47099e3f8a85df9e1b8037d4180ee26b6795bccb1a35 esr-metainfo.patch
+f7b3b45ba04d05d17439d009bf0c9f27881e126f424e2257552338a0c1e3771ee1289c044babcb0920f62af62873a268c0cf524e1d35711e6dc8b808ca5e9f26 esr-metainfo.patch
2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
cd68b89e29e5f6379fbd5679db27b9a5ef70ea65e51c0d0a8137e1f1fd210e35a8cfb047798e9549bc7275606d7ec5c8d8af1335d29da4699db7acd8bc7ff556 fix-rust-target.patch
305c874fdea3096e9c4c6aa6520ac64bb1c347c4b59db8360096646593fe684c3b5377874d91cecd33d56d1410b4714fbdea2b514923723ecbeff79d51265d9b fix-webrtc-glibcisms.patch
-a4a3e062661bda64d502d426c480ac9645345860118de9df9ffe6e0597738c70c11e5cdef2d4fd12c5e2ee30a09310159230524655a419a4f7e4eeeb0f3c06b0 mallinfo.patch
-f3d419880cc7f043b6eb547894d486457d407640be2bd8b402eb3a534ccea39568f6d506fc44a3b29c94eb0dc6fc2bec6600d161786fd233d26b1dc8970f5ab4 python-deps.patch
-b4b264423d8dff97294d6723bfe67e98ba5ed24b2e8e05d5af6ad3f4a1dff3012e36211ee47915abd9743c8bce20da89df1bb48a6608add8e97f2c9360e7276f rust-1.63.patch
+afabea91b328c5a68eaa20f9099ac7b2d0e7f2423e816b05ed168bdd326a5684fa02de08bf05c6033e9b888f02775d1b0443a00329b7a632ee399122a391c13a icu74.patch
+5fa9382c692e4bd6a2634308f24a6526fd12a60a2563d2090056d43a60505df3ec9881bbf54562e69394467529b3b0dc45955afca46ed329af03cea074fff070 lfs64.patch
+c0437a6753f3f350968fa12d250efdfe1bea77baf0e4c06b072b5cc9e78c774dbf4506bc536337030d349fb3ba4460097b75b0c7c5b8fb2d39d8b0a392948936 no-ccache-stats.patch
+2d8dff86212d6d2a904cbb5a5a1d6c17b89adc929fc6a3f4c6cb669f5e83ecddff5a799225319ba445a187b04d111251af75dd3ce8a039164bc14d2a432a2a04 ppc-musttail.patch
+6f60e83599041db1b707c21784197ea9816b2c936b89a274bfc24554a600981e6f28448fe41fab0942bd31acd49b1c00beb2eb0961149f2ffa6a4154be123ea7 ppc-webrtc.patch
+4e40b34c5f77a1a21fe971a6fcd8a21b1a63423a3a7932a5a6e1c7a2779f9f06a561c806614a01931679a4b1c6afdfd8ae1f3cc6b673f259ccd368e8e54f6e90 python-deps.patch
+1c6918dd6655d3a1251bfd4af2e1c561cbb00d540a883b4c1ebf7f5de530d754d9ac07b4b5f56cdab6c511d25c8910ec94043f5733e97501a67abffe1bafaeb1 rust-lto-thin.patch
2518f2fc75b5db30058e0735f47d60fdf1e7adfaeee4b33fb2afb1bd9a616ce943fd88f4404d0802d4083703f4acf1d5ad42377218d025bc768807fbaf7e1609 sandbox-fork.patch
b7d0a6126bdf6c0569f80aabf5b37ed2c7a35712eb8a0404a2d85381552f5555d4f97d213ea26cec6a45dc2785f22439376ed5f8e78b4fd664ef0223307b333e sandbox-largefile.patch
-94433c5ffdbe579c456d95c5f053f61fcbab2f652fa90bc69dcc27d9a1507a8e5c677adeadae9a7a75cc9a55184c1040737f4dfd10b279c088ef016561e6f135 sandbox-sched_setscheduler.patch
+f8c3555ef6207933cbffbf4fc101a9b4c0d2990c0063162f0f0bde70ef0b46f86bfac42e7110695183424a87948de593f3927b2d8509ede3e4fc7bd8a1fad1ce sandbox-sched_setscheduler.patch
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
-838901879006aaa26155cedf9f0244f543fe7ea9a78e03e499183da5611ee68b00e40f9790b47c0cb515291fc540b7bd21b469bb5a7383b4c510f17e44f898d4 firefox-safe.desktop
-4560083a0642ba2764539e56cdd45a8d5c1a7a5855f8b09b7f5f7a3c107520a2b6aac84df62a24394f18003c0429ad3f177342c1667e40820870d7d950975bc1 firefox.desktop
+d354f48a29bfc16719f3b230b1395063239d4420f9e47522de4662392d9697b15f931ca3bf6055d100fa33d61a9a1a13477687d5eac99e50ae7dbef9882a5808 firefox.desktop
+382510375b1a2fa79be0ab79e3391a021ae2c022429ffbaa7e7a69166f99bb56d01e59a1b10688592a29238f21c9d6977672bd77f9fae439b66bdfe0c55ddb15 mozilla-location.keys
fc45bc3ffb9404e5338ea26a9f04807b40f6f516324972cddd48bedb91b8bd7c6b8d4e03a0209020f5e67b703bc4ff89389985791b9bd544a0fc3951e2dc338e vendor-prefs.js
"