aboutsummaryrefslogtreecommitdiffstats
path: root/community/firefox-esr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/firefox-esr/APKBUILD')
-rw-r--r--community/firefox-esr/APKBUILD633
1 files changed, 481 insertions, 152 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index 12aa8b9f1fc..74824992b22 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -1,10 +1,11 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=firefox-esr
-pkgver=91.5.0
+pkgver=115.9.1
# Date of release, YY-MM-DD for metainfo file (see package())
-_releasedate=2022-01-11
+# https://www.mozilla.org/firefox/organizations/notes/
+_releasedate=2024-03-22
pkgrel=0
pkgdesc="Firefox web browser - Extended Support Release"
url="https://www.mozilla.org/en-US/firefox/organizations/"
@@ -12,20 +13,25 @@ url="https://www.mozilla.org/en-US/firefox/organizations/"
# armhf: build failure on armhf due to wasm
arch="x86_64 armv7 aarch64 x86 ppc64le"
license="GPL-3.0-only AND LGPL-2.1-only AND LGPL-3.0-only AND MPL-2.0"
+install="$pkgname.post-upgrade"
+depends="
+ ffmpeg-libavcodec
+ "
makedepends="
alsa-lib-dev
automake
bsd-compat-headers
cargo
- cbindgen>=0.18.0
- clang-dev
+ cbindgen
+ clang
+ clang-libclang
dbus-glib-dev
- ffmpeg-dev
+ gettext
gtk+3.0-dev
hunspell-dev
icu-dev>=69.1
libevent-dev
- libidl-dev
+ libffi-dev
libjpeg-turbo-dev
libnotify-dev
libogg-dev
@@ -33,59 +39,299 @@ makedepends="
libtool
libvorbis-dev
libvpx-dev
- libxt-dev
+ libwebp-dev
libxcomposite-dev
+ libxt-dev
+ lld
llvm-dev
m4
mesa-dev
nasm
nodejs
nspr-dev
- nss-dev>=3.44.1
- nss-static
+ nss-dev
+ pipewire-dev
+ pulseaudio-dev
+ py3-psutil
+ py3-zstandard
python3
sed
+ wasi-sdk
wireless-tools-dev
- yasm
zip
- libffi-dev
- libwebp-dev
- pipewire-dev
- gettext
- pulseaudio-dev
"
-
+subpackages="$pkgname-intl"
source="https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz
- stab.h
-
- fix-fortify-system-wrappers.patch
- fix-tools.patch
- mallinfo.patch
-
+ audio-lfs64.patch
disable-moz-stackwalk.patch
+ esr-metainfo.patch
+ fix-fortify-system-wrappers.patch
fix-rust-target.patch
fix-webrtc-glibcisms.patch
- allow-custom-rust-vendor.patch
-
- firefox.desktop
- firefox-safe.desktop
- disable-neon-in-aom.patch
+ icu74.patch
+ lfs64.patch
+ no-ccache-stats.patch
+ ppc-musttail.patch
+ ppc-webrtc.patch
+ python-deps.patch
+ rust-lto-thin.patch
sandbox-fork.patch
- sandbox-sched_setscheduler.patch
sandbox-largefile.patch
+ sandbox-sched_setscheduler.patch
- avoid-redefinition.patch
+ stab.h
- mozwayland-add-missing-stub.patch
+ firefox.desktop
+ mozilla-location.keys
+ vendor-prefs.js
"
builddir="$srcdir/firefox-$pkgver"
-_mozappdir=/usr/lib/firefox
+_mozappdir=/usr/lib/firefox-esr
# help our shared-object scanner to find the libs
ldpath="$_mozappdir"
# secfixes:
+# 115.6.0-r0:
+# - CVE-2023-6856
+# - CVE-2023-6865
+# - CVE-2023-6857
+# - CVE-2023-6858
+# - CVE-2023-6859
+# - CVE-2023-6860
+# - CVE-2023-6867
+# - CVE-2023-6861
+# - CVE-2023-6862
+# - CVE-2023-6863
+# - CVE-2023-6864
+# 115.5.0-r0:
+# - CVE-2023-6204
+# - CVE-2023-6205
+# - CVE-2023-6206
+# - CVE-2023-6207
+# - CVE-2023-6208
+# - CVE-2023-6209
+# - CVE-2023-6212
+# 115.4.0-r0:
+# - CVE-2023-5721
+# - CVE-2023-5732
+# - CVE-2023-5724
+# - CVE-2023-5725
+# - CVE-2023-5726
+# - CVE-2023-5727
+# - CVE-2023-5728
+# - CVE-2023-5730
+# 115.3.1-r0:
+# - CVE-2023-5217
+# 115.3.0-r0:
+# - CVE-2023-5168
+# - CVE-2023-5169
+# - CVE-2023-5171
+# - CVE-2023-5174
+# - CVE-2023-5176
+# 115.2.1-r0:
+# - CVE-2023-4863
+# 115.2.0-r0:
+# - CVE-2023-4573
+# - CVE-2023-4574
+# - CVE-2023-4575
+# - CVE-2023-4576
+# - CVE-2023-4577
+# - CVE-2023-4051
+# - CVE-2023-4578
+# - CVE-2023-4053
+# - CVE-2023-4580
+# - CVE-2023-4581
+# - CVE-2023-4582
+# - CVE-2023-4583
+# - CVE-2023-4584
+# - CVE-2023-4585
+# 115.1.0-r0:
+# - CVE-2023-4045
+# - CVE-2023-4046
+# - CVE-2023-4047
+# - CVE-2023-4048
+# - CVE-2023-4049
+# - CVE-2023-4050
+# - CVE-2023-4052
+# - CVE-2023-4054
+# - CVE-2023-4055
+# - CVE-2023-4056
+# - CVE-2023-4057
+# 115.0.2-r0:
+# - CVE-2023-3600
+# 115.0-r0:
+# - CVE-2023-3482
+# - CVE-2023-37201
+# - CVE-2023-37202
+# - CVE-2023-37203
+# - CVE-2023-37204
+# - CVE-2023-37205
+# - CVE-2023-37206
+# - CVE-2023-37207
+# - CVE-2023-37208
+# - CVE-2023-37209
+# - CVE-2023-37210
+# - CVE-2023-37211
+# - CVE-2023-37212
+# 102.12.0-r0:
+# - CVE-2023-34414
+# - CVE-2023-34416
+# 102.11.0-r0:
+# - CVE-2023-32205
+# - CVE-2023-32206
+# - CVE-2023-32207
+# - CVE-2023-32211
+# - CVE-2023-32212
+# - CVE-2023-32213
+# - CVE-2023-32214
+# - CVE-2023-32215
+# 102.10.0-r0:
+# - CVE-2023-29531
+# - CVE-2023-29532
+# - CVE-2023-29533
+# - CVE-2023-1999
+# - CVE-2023-29535
+# - CVE-2023-29536
+# - CVE-2023-29539
+# - CVE-2023-29541
+# - CVE-2023-29542
+# - CVE-2023-29545
+# - CVE-2023-1945
+# - CVE-2023-29548
+# - CVE-2023-29550
+# 102.9.0-r0:
+# - CVE-2023-25751
+# - CVE-2023-28164
+# - CVE-2023-28162
+# - CVE-2023-25752
+# - CVE-2023-28163
+# - CVE-2023-28176
+# 102.8.0-r0:
+# - CVE-2023-25728
+# - CVE-2023-25730
+# - CVE-2023-0767
+# - CVE-2023-25735
+# - CVE-2023-25737
+# - CVE-2023-25738
+# - CVE-2023-25739
+# - CVE-2023-25729
+# - CVE-2023-25732
+# - CVE-2023-25734
+# - CVE-2023-25742
+# - CVE-2023-25744
+# - CVE-2023-25746
+# 102.7.0-r0:
+# - CVE-2022-46871
+# - CVE-2023-23598
+# - CVE-2023-23599
+# - CVE-2023-23601
+# - CVE-2023-23602
+# - CVE-2022-46877
+# - CVE-2023-23603
+# - CVE-2023-23605
+# 102.6.0-r0:
+# - CVE-2022-46880
+# - CVE-2022-46872
+# - CVE-2022-46881
+# - CVE-2022-46874
+# - CVE-2022-46875
+# - CVE-2022-46882
+# - CVE-2022-46878
+# 102.5.0-r0:
+# - CVE-2022-45403
+# - CVE-2022-45404
+# - CVE-2022-45405
+# - CVE-2022-45406
+# - CVE-2022-45408
+# - CVE-2022-45409
+# - CVE-2022-45410
+# - CVE-2022-45411
+# - CVE-2022-45412
+# - CVE-2022-45416
+# - CVE-2022-45418
+# - CVE-2022-45420
+# - CVE-2022-45421
+# 102.4.0-r0:
+# - CVE-2022-42927
+# - CVE-2022-42928
+# - CVE-2022-42929
+# - CVE-2022-42932
+# 102.3.0-r0:
+# - CVE-2022-3266
+# - CVE-2022-40959
+# - CVE-2022-40960
+# - CVE-2022-40958
+# - CVE-2022-40956
+# - CVE-2022-40957
+# - CVE-2022-40962
+# 102.2.0-r0:
+# - CVE-2022-38472
+# - CVE-2022-38473
+# - CVE-2022-38476
+# - CVE-2022-38477
+# - CVE-2022-38478
+# 102.1.0-r0:
+# - CVE-2022-2505
+# - CVE-2022-36314
+# - CVE-2022-36318
+# - CVE-2022-36319
+# 91.11.0-r0:
+# - CVE-2022-2200
+# - CVE-2022-31744
+# - CVE-2022-34468
+# - CVE-2022-34470
+# - CVE-2022-34472
+# - CVE-2022-34478
+# - CVE-2022-34479
+# - CVE-2022-34481
+# - CVE-2022-34484
+# 91.10.0-r0:
+# - CVE-2022-31736
+# - CVE-2022-31737
+# - CVE-2022-31738
+# - CVE-2022-31739
+# - CVE-2022-31740
+# - CVE-2022-31741
+# - CVE-2022-31742
+# - CVE-2022-31747
+# 91.9.1-r0:
+# - CVE-2022-1529
+# - CVE-2022-1802
+# 91.9.0-r0:
+# - CVE-2022-29909
+# - CVE-2022-29911
+# - CVE-2022-29912
+# - CVE-2022-29914
+# - CVE-2022-29916
+# - CVE-2022-29917
+# 91.8.0-r0:
+# - CVE-2022-1097
+# - CVE-2022-1196
+# - CVE-2022-24713
+# - CVE-2022-28281
+# - CVE-2022-28282
+# - CVE-2022-28285
+# - CVE-2022-28286
+# - CVE-2022-28289
+# 91.7.0-r0:
+# - CVE-2022-26381
+# - CVE-2022-26383
+# - CVE-2022-26384
+# - CVE-2022-26386
+# - CVE-2022-26387
+# 91.6.1-r0:
+# - CVE-2022-26485
+# - CVE-2022-26486
+# 91.6.0-r0:
+# - CVE-2022-22754
+# - CVE-2022-22756
+# - CVE-2022-22759
+# - CVE-2022-22760
+# - CVE-2022-22761
+# - CVE-2022-22763
+# - CVE-2022-22764
# 91.5.0-r0:
# - CVE-2021-4140
# - CVE-2022-22737
@@ -362,162 +608,245 @@ _clear_vendor_checksums() {
sed -i 's/\("files":{\)[^}]*/\1/' third_party/rust/$1/.cargo-checksum.json
}
+export SHELL=/bin/sh
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export USE_SHORT_LIBNAME=1
+export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
+export MOZ_APP_PROFILE="mozilla/firefox"
+export MOZ_APP_REMOTINGNAME=firefox-esr
+export MOZBUILD_STATE_PATH="$srcdir"/mozbuild
+# disable desktop notifications
+export MOZ_NOSPAM=1
+# Find our triplet JSON
+export RUST_TARGET="$CTARGET"
+
+# Build with Clang, takes less RAM
+export CC="clang"
+export CXX="clang++"
+
+# set rpath so linker finds the libs
+export LDFLAGS="$LDFLAGS -Wl,-rpath,$_mozappdir"
+
+# let firefox do this itself.
+unset CARGO_PROFILE_RELEASE_OPT_LEVEL
+unset CARGO_PROFILE_RELEASE_LTO
+
+export CFLAGS="${CFLAGS/-fstack-clash-protection/} -g0 -O2"
+export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection/} -g0 -O2 -Wno-deprecated-builtins -Wno-deprecated-declarations"
+
prepare() {
default_prepare
cp "$srcdir"/stab.h toolkit/crashreporter/google-breakpad/src/
_clear_vendor_checksums audio_thread_priority
- _clear_vendor_checksums target-lexicon-0.9.0
+
+ base64 -d "$srcdir"/mozilla-location.keys > "$builddir"/mozilla-api-key
+
+ # webrtc does not build on these
+ case "$CARCH" in
+ ppc64le)
+ local webrtc_config="ac_add_options --disable-webrtc"
+ ;;
+ esac
+ case "$CARCH" in
+ armv7)
+ # broken here
+ local rust_simd="ac_add_options --disable-rust-simd"
+ ;;
+ *)
+ local rust_simd="ac_add_options --enable-rust-simd"
+ ;;
+ esac
+
+ case "$CARCH" in
+ aarch64|arm*|x86*)
+ # disable-elf-hack: exists only on aarch64, arm*, x86, x86_64
+ local arch_config="ac_add_options --disable-elf-hack"
+ ;;
+ esac
+
+ # sandbox only supported here
+ case "$CARCH" in
+ x86*|armv7|aarch64)
+ local sandbox="ac_add_options --enable-sandbox"
+ ;;
+ *)
+ local sandbox="ac_add_options --disable-sandbox"
+ ;;
+ esac
+
+ cat > base-mozconfig <<-EOF
+ # disable unwanted things
+ ac_add_options --disable-bootstrap
+ ac_add_options --disable-cargo-incremental
+ ac_add_options --disable-crashreporter
+ ac_add_options --disable-debug
+ ac_add_options --disable-debug-symbols
+ ac_add_options --disable-install-strip
+ ac_add_options --disable-jemalloc
+ ac_add_options --disable-strip
+ ac_add_options --disable-tests
+ ac_add_options --disable-updater
+
+ # features
+ ac_add_options --enable-alsa
+ ac_add_options --enable-dbus
+ ac_add_options --enable-default-toolkit=cairo-gtk3-wayland
+ ac_add_options --enable-ffmpeg
+ ac_add_options --enable-hardening
+ ac_add_options --enable-linker=lld
+ ac_add_options --enable-necko-wifi
+ ac_add_options --enable-official-branding
+ ac_add_options --enable-optimize="$CFLAGS"
+ ac_add_options --enable-pulseaudio
+ ac_add_options --enable-release
+ ac_add_options --enable-update-channel=release
+
+ # system libs
+ ac_add_options --enable-system-pixman
+ ac_add_options --with-system-ffi
+ ac_add_options --with-system-icu
+ ac_add_options --with-system-jpeg
+ ac_add_options --with-system-libevent
+ ac_add_options --with-system-libvpx
+ ac_add_options --with-system-nspr
+ ac_add_options --with-system-nss
+ ac_add_options --with-system-png
+ ac_add_options --with-system-webp
+ ac_add_options --with-system-zlib
+
+ # misc
+ ac_add_options --allow-addon-sideload
+ ac_add_options --prefix=/usr
+ ac_add_options --with-app-name=firefox-esr
+ ac_add_options --with-distribution-id=org.alpinelinux
+ ac_add_options --with-libclang-path=/usr/lib
+ ac_add_options --with-unsigned-addon-scopes=app,system
+ ac_add_options --with-wasi-sysroot=/usr/share/wasi-sysroot
+ ac_add_options --host=$CHOST
+ ac_add_options --target=$CTARGET
+
+ # objdir
+ mk_add_options MOZ_OBJDIR="$builddir/obj"
+
+ mk_add_options RUSTFLAGS="$RUSTFLAGS"
+
+ # keys
+ # these are for alpine linux use only
+ ac_add_options --with-mozilla-api-keyfile="$builddir/mozilla-api-key"
+
+ $arch_config
+ $rust_simd
+ $sandbox
+ $webrtc_config
+ EOF
}
build() {
- mkdir -p "$builddir"/objdir
- cd "$builddir"/objdir
-
- export SHELL=/bin/sh
- export BUILD_OFFICIAL=1
- export MOZILLA_OFFICIAL=1
- export USE_SHORT_LIBNAME=1
- export MACH_USE_SYSTEM_PYTHON=1
- # Find our triplet JSON
- export RUST_TARGET="$CTARGET"
- # Build with Clang, takes less RAM
- export CC="clang"
- export CXX="clang++"
-
- # set rpath so linker finds the libs
- export LDFLAGS="$LDFLAGS -Wl,-rpath,$_mozappdir"
+ cat > .mozconfig base-mozconfig
+
+ export MOZ_BUILD_DATE=$(date ${SOURCE_DATE_EPOCH:+ -d@${SOURCE_DATE_EPOCH}} "+%Y%m%d%H%M%S")
+
+ # for lto
+ ulimit -n 4096
+
+ # can't be set here and fail
+ unset RUSTFLAGS
+
+ local thinlto_jobs=${JOBS:-1}
case "$CARCH" in
- arm*|x86*)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- ;;
+ # on this platforms, lld seems to not utilise >1 threads for thinlto for some reason.
+ # at the same time, having more than 8 also crashes lld for firefox buildsystems (why?).
+ aarch64)
+ if [ $thinlto_jobs -gt 8 ]; then
+ thinlto_jobs=8
+ fi
+ ;;
esac
- # FF doesn't have SIMD available on these arches.
+ export LDFLAGS="$LDFLAGS -Wl,--thinlto-jobs=$thinlto_jobs"
+
case "$CARCH" in
- armhf|armv7)
- _rust_simd="--disable-rust-simd"
- _low_mem_flags="--disable-debug-symbols --disable-debug"
- export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0"
- ;;
- x86)
- _low_mem_flags="--disable-debug-symbols --disable-debug"
- export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0"
- ;;
- *) _rust_simd="--enable-rust-simd" ;;
+ # lto for 64-bit systems only
+ aarch64|x86_64|ppc64le)
+ cat > .mozconfig base-mozconfig <<-EOF
+ ac_add_options --enable-lto=cross
+ EOF
esac
- ../mach configure \
- --prefix=/usr \
- $_arch_config \
- $_low_mem_flags \
- $_rust_simd \
- \
- --disable-crashreporter \
- --disable-gold \
- --disable-install-strip \
- --disable-jemalloc \
- --disable-profiling \
- --disable-strip \
- --disable-tests \
- --disable-updater \
- \
- --enable-alsa \
- --enable-dbus \
- --enable-default-toolkit=cairo-gtk3-wayland \
- --enable-ffmpeg \
- --enable-hardening \
- --enable-necko-wifi \
- --enable-official-branding \
- --enable-optimize="$CFLAGS -O2" \
- --enable-pulseaudio \
- --disable-smoosh \
- --enable-system-ffi \
- --enable-system-pixman \
- \
- --with-system-ffi \
- --with-system-icu \
- --with-system-jpeg \
- --with-system-libevent \
- --with-system-libvpx \
- --with-system-nspr \
- --with-system-nss \
- --with-system-pixman \
- --with-system-png \
- --with-system-webp \
- --with-system-zlib \
- --with-clang-path=/usr/bin/clang \
- --with-libclang-path=/usr/lib
- ../mach build
+ ./mach build
}
package() {
- cd "$builddir"/objdir
-
- DESTDIR="$pkgdir" MOZ_MAKE_FLAGS="$MAKEOPTS" ../mach install
-
- install -m755 -d "$pkgdir"/usr/share/applications
- install -m755 -d "$pkgdir"/usr/share/pixmaps
+ DESTDIR="$pkgdir" ./mach install
local _png
- for _png in ../browser/branding/official/default*.png; do
+ for _png in ./browser/branding/official/default*.png; do
local i=${_png%.png}
i=${i##*/default}
- install -D -m644 "$_png" "$pkgdir"/usr/share/icons/hicolor/"$i"x"$i"/apps/firefox.png
+ install -Dm644 "$_png" \
+ "$pkgdir"/usr/share/icons/hicolor/"$i"x"$i"/apps/firefox-esr.png
done
- install -m644 "$builddir"/browser/branding/official/default48.png \
- "$pkgdir"/usr/share/pixmaps/firefox.png
- install -m644 "$srcdir"/firefox.desktop "$pkgdir"/usr/share/applications/org.mozilla.firefox.desktop
- install -m644 "$srcdir"/firefox-safe.desktop "$pkgdir"/usr/share/applications/org.mozilla.firefox-safe.desktop
+ install -Dm644 browser/branding/official/content/about-logo.png \
+ "$pkgdir"/usr/share/icons/hicolor/192x192/apps/firefox-esr.png
+ install -Dm644 browser/branding/official/content/about-logo@2x.png \
+ "$pkgdir"/usr/share/icons/hicolor/384x384/apps/firefox-esr.png
+ install -Dm644 browser/branding/official/content/about-logo.svg \
+ "$pkgdir"/usr/share/icons/hicolor/scalable/apps/firefox-esr.svg
- # Add StartupWMClass=firefox on the .desktop files so Desktop Environments
- # correctly associate the window with their icon, the correct fix is to have
- # firefox sets its own AppID but this will work for the meantime
- # See: https://bugzilla.mozilla.org/show_bug.cgi?id=1607399
- echo "StartupWMClass=firefox" >> "$pkgdir"/usr/share/applications/org.mozilla.firefox.desktop
- echo "StartupWMClass=firefox" >> "$pkgdir"/usr/share/applications/org.mozilla.firefox-safe.desktop
+ install -Dm644 "$srcdir"/firefox.desktop \
+ "$pkgdir"/usr/share/applications/firefox-esr.desktop
# install our vendor prefs
- install -d "$pkgdir"/$_mozappdir/browser/defaults/preferences
-
- cat >> "$pkgdir"/$_mozappdir/browser/defaults/preferences/firefox-branding.js <<- EOF
- // Use LANG environment variable to choose locale
- pref("intl.locale.requested", "");
-
- // Disable default browser checking.
- pref("browser.shell.checkDefaultBrowser", false);
-
- // Don't disable our bundled extensions in the application directory
- pref("extensions.autoDisableScopes", 11);
- pref("extensions.shownSelectionUI", true);
- EOF
+ install -Dm644 "$srcdir"/vendor-prefs.js \
+ "$pkgdir"/$_mozappdir/browser/defaults/preferences/vendor.js
# Generate appdata file
- mkdir "$pkgdir"/usr/share/metainfo/
+ mkdir -p "$pkgdir"/usr/share/metainfo/
export VERSION="$pkgver"
export DATE="$_releasedate"
- envsubst < "$builddir"/taskcluster/docker/firefox-flatpak/org.mozilla.firefox.appdata.xml.in > "$pkgdir"/usr/share/metainfo/org.mozilla.firefox.appdata.xml
+ envsubst < "$builddir"/taskcluster/docker/firefox-flatpak/org.mozilla.firefox.appdata.xml.in > "$pkgdir"/usr/share/metainfo/org.mozilla.firefox-esr.appdata.xml
+
+ # Replace duplicate binary with wrapper
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ install -Dm755 /dev/stdin "$pkgdir"/usr/bin/firefox-esr <<- EOF
+ #!/bin/sh
+ exec $_mozappdir/firefox-esr "\$@"
+ EOF
+ rm "$pkgdir"/$_mozappdir/firefox-esr-bin
+ ln -sfv /usr/bin/firefox-esr "$pkgdir"/$_mozappdir/firefox-esr-bin
+}
+
+intl() {
+ pkgdesc="$pkgname - International ICU data"
+ depends="icu-data-full"
+ install_if="$pkgname=$pkgver-r$pkgrel icu"
+ mkdir -p "$subpkgdir"
}
sha512sums="
-1712415b6b73c6a21edfefc39eaba5fcbbca54032f78627c0005d291501d16ef4daffb8b9a160d1d5361113ceba04eb5ddb21d903e3dd8d58838aa9596f2d781 firefox-91.5.0esr.source.tar.xz
-0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
-2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
-4510fb92653d0fdcfbc6d30e18087c0d22d4acd5eb53be7d0a333abe087a9e0bf9e58e56bafe96e1e1b28ebd1fd33b8926dbb70c221007e335b33d1468755c66 fix-tools.patch
-a4a3e062661bda64d502d426c480ac9645345860118de9df9ffe6e0597738c70c11e5cdef2d4fd12c5e2ee30a09310159230524655a419a4f7e4eeeb0f3c06b0 mallinfo.patch
+9ccaede2fcda13a07f98a2110bb8f99c7324601d66bff311f3070a669576a1598fe1d7de2d005d725d1f44dbe3934a9c0fd0b7950f60686047d4ce8d9d812310 firefox-115.9.1esr.source.tar.xz
+3e0501ae7a650346c667dfdc0ae0ca286084f22e89ab2ac671cc0d7315673dc5b6dcb9f9882f6f39d26e9a31e57f7a0fd53d6b805e520224e22b8976850e2eb8 audio-lfs64.patch
454ea3263cabce099accbdc47aaf83be26a19f8b5a4568c01a7ef0384601cf8315efd86cd917f9c8bf419c2c845db89a905f3ff9a8eb0c8e41042e93aa96a85c disable-moz-stackwalk.patch
+f7b3b45ba04d05d17439d009bf0c9f27881e126f424e2257552338a0c1e3771ee1289c044babcb0920f62af62873a268c0cf524e1d35711e6dc8b808ca5e9f26 esr-metainfo.patch
+2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
cd68b89e29e5f6379fbd5679db27b9a5ef70ea65e51c0d0a8137e1f1fd210e35a8cfb047798e9549bc7275606d7ec5c8d8af1335d29da4699db7acd8bc7ff556 fix-rust-target.patch
-47c2c2428c3598a42f6241705179642b3378a86ace39c8c3cbef4954e6d220b42e6c76f3d71731d65f67ce2c8597259122ac44bbd45e20993bb8bc70c0c8a010 fix-webrtc-glibcisms.patch
-4e584621145cf8add069c6dac18e805b3274a1ee402d84e924df2341f7d3c5be261a93ef51283bacbd606f47fbdc628c4323ecc31efc5b403b8d224b18dc278f allow-custom-rust-vendor.patch
-f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
-5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop
-55eab1a02e19a19a1ee0e36b11097ab48a44200e07e543d91469967206854f39709c7c0bc31855559528e64642d610868140e9533f1c0e3bebc953353c142fa8 disable-neon-in-aom.patch
+305c874fdea3096e9c4c6aa6520ac64bb1c347c4b59db8360096646593fe684c3b5377874d91cecd33d56d1410b4714fbdea2b514923723ecbeff79d51265d9b fix-webrtc-glibcisms.patch
+afabea91b328c5a68eaa20f9099ac7b2d0e7f2423e816b05ed168bdd326a5684fa02de08bf05c6033e9b888f02775d1b0443a00329b7a632ee399122a391c13a icu74.patch
+5fa9382c692e4bd6a2634308f24a6526fd12a60a2563d2090056d43a60505df3ec9881bbf54562e69394467529b3b0dc45955afca46ed329af03cea074fff070 lfs64.patch
+c0437a6753f3f350968fa12d250efdfe1bea77baf0e4c06b072b5cc9e78c774dbf4506bc536337030d349fb3ba4460097b75b0c7c5b8fb2d39d8b0a392948936 no-ccache-stats.patch
+2d8dff86212d6d2a904cbb5a5a1d6c17b89adc929fc6a3f4c6cb669f5e83ecddff5a799225319ba445a187b04d111251af75dd3ce8a039164bc14d2a432a2a04 ppc-musttail.patch
+6f60e83599041db1b707c21784197ea9816b2c936b89a274bfc24554a600981e6f28448fe41fab0942bd31acd49b1c00beb2eb0961149f2ffa6a4154be123ea7 ppc-webrtc.patch
+4e40b34c5f77a1a21fe971a6fcd8a21b1a63423a3a7932a5a6e1c7a2779f9f06a561c806614a01931679a4b1c6afdfd8ae1f3cc6b673f259ccd368e8e54f6e90 python-deps.patch
+1c6918dd6655d3a1251bfd4af2e1c561cbb00d540a883b4c1ebf7f5de530d754d9ac07b4b5f56cdab6c511d25c8910ec94043f5733e97501a67abffe1bafaeb1 rust-lto-thin.patch
2518f2fc75b5db30058e0735f47d60fdf1e7adfaeee4b33fb2afb1bd9a616ce943fd88f4404d0802d4083703f4acf1d5ad42377218d025bc768807fbaf7e1609 sandbox-fork.patch
-db26757b2ebf9f567962e32294b4ae48b3a5d0378a7589dfe650fe3a179ff58befbab5082981c68e1c25fb9e56b2db1e4e510d4bca17c3e3aedbf9a2f21806eb sandbox-sched_setscheduler.patch
b7d0a6126bdf6c0569f80aabf5b37ed2c7a35712eb8a0404a2d85381552f5555d4f97d213ea26cec6a45dc2785f22439376ed5f8e78b4fd664ef0223307b333e sandbox-largefile.patch
-b1cb2db3122634f66d2bae7066e76f2dcd455c464e021db4de3b0a08314df95cb667846081682db549dd2af8a00831cabe44a2420c66cdfb5e3b5fa7e6bd21d3 avoid-redefinition.patch
-8c303539829a5c9ada43c8b03a9eae37fad68fcbc78deb3129857bfe852f582357efdaf8f506944394a97bef23cc89fefc00f3edf633edfcdd007a75dad8d746 mozwayland-add-missing-stub.patch
+f8c3555ef6207933cbffbf4fc101a9b4c0d2990c0063162f0f0bde70ef0b46f86bfac42e7110695183424a87948de593f3927b2d8509ede3e4fc7bd8a1fad1ce sandbox-sched_setscheduler.patch
+0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
+d354f48a29bfc16719f3b230b1395063239d4420f9e47522de4662392d9697b15f931ca3bf6055d100fa33d61a9a1a13477687d5eac99e50ae7dbef9882a5808 firefox.desktop
+382510375b1a2fa79be0ab79e3391a021ae2c022429ffbaa7e7a69166f99bb56d01e59a1b10688592a29238f21c9d6977672bd77f9fae439b66bdfe0c55ddb15 mozilla-location.keys
+fc45bc3ffb9404e5338ea26a9f04807b40f6f516324972cddd48bedb91b8bd7c6b8d4e03a0209020f5e67b703bc4ff89389985791b9bd544a0fc3951e2dc338e vendor-prefs.js
"